Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 15-02-2017, 12:45   #11
altan888
Altın Üye
 
altan888 kullanıcısının avatarı
 
Giriş: 15/02/2008
Şehir: İzmir
Mesaj: 184
Excel Vers. ve Dili:
Excel 2016 TR
Varsayılan

Tüm cevaplar için çok teşekkürler...
altan888 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 15-02-2017, 12:53   #12
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,243
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Sayfayı yenileyerek son cevabıma tekrar bakınız, birkaç açıklama ekledim ve yeni formül verdim.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 15-02-2017, 14:08   #13
Murat OSMA
Altın Üye
 
Murat OSMA kullanıcısının avatarı
 
Giriş: 23/05/2011
Şehir: İstanbul
Mesaj: 4,861
Excel Vers. ve Dili:
Excel 2016 - Türkçe
Varsayılan

Alternatif..

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(SOLDAN(A2;2)="FT";PARÇAAL(A2;MBUL("İLE";A2)+4;MBUL("STO";A2)-MBUL("İLE";A2)-5);YERİNEKOY(SOLDAN(A2;MBUL("İLE";A2)-2);"FATURA ";""))
__________________
Excel'e dair her şey; excelarsivi.com 'da..
Murat OSMA Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-02-2017, 19:18   #14
altan888
Altın Üye
 
altan888 kullanıcısının avatarı
 
Giriş: 15/02/2008
Şehir: İzmir
Mesaj: 184
Excel Vers. ve Dili:
Excel 2016 TR
Varsayılan

Alıntı:
Ömer BARAN tarafından gönderildi Mesajı Görüntüle
Belgenizde A sütunundaki metinler;
-- FATURA şeklinde başlıyorsa,FATURA kelimesinden sonra başlayıp, ilk İLE kelimesine kadarki kısım,
-- FT şeklinde başlıyorsa, İLE kelimesiyle STOPAJ kelimesinin arasındaki kısım,
-- AD SOYAD'la başlıyorsa, İLE kelimesine kadarki kısım
aradığımız AD SOYAD oluyor.

Verdiğim formülü buna göre sanırım daha da kısaltmak mümkün oluyor.
(verdiğim ilk formül metni uzunluğu 1090, ikinci verdiğim formül metni uzunluğu 391 karakter, aşağıdakinin ise 186 karakter, kullanılan işlev sayıları arasında da benzer farklılıklar var elbette.)
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=KIRP(
EĞER(SOLDAN(A2;6)="FATURA";PARÇAAL(A2;8;BUL("İLE";A2;1)-8);
EĞER(SOLDAN(A2;2)="FT";PARÇAAL(A2;BUL("İLE";A2;1)+3;BUL("STOPAJ";A2;1)-BUL("İLE";A2;1)-3);
SOLDAN(A2;BUL("İLE";A2;1)-1)))
)
Çok teşekkürler
altan888 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-02-2017, 19:19   #15
altan888
Altın Üye
 
altan888 kullanıcısının avatarı
 
Giriş: 15/02/2008
Şehir: İzmir
Mesaj: 184
Excel Vers. ve Dili:
Excel 2016 TR
Varsayılan

Alıntı:
Murat OSMA tarafından gönderildi Mesajı Görüntüle
Alternatif..

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(SOLDAN(A2;2)="FT";PARÇAAL(A2;MBUL("İLE";A2)+4;MBUL("STO";A2)-MBUL("İLE";A2)-5);YERİNEKOY(SOLDAN(A2;MBUL("İLE";A2)-2);"FATURA ";""))
Çok Teşekkürler
altan888 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-02-2017, 22:25   #16
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,243
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Alıntı:
altan888 tarafından gönderildi Mesajı Görüntüle
Çok teşekkürler
Kolay gelsin.
.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 07:28


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri- Çorlu Çelik Konstruksiyon-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden