Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 17-03-2017, 20:11   #1
klop01
Altın Üye
 
Giriş: 19/12/2016
Şehir: Muğla
Mesaj: 80
Excel Vers. ve Dili:
2016 Türkçe 64 Bit Pro
Varsayılan Formüldeki metinsel ifade hatası

Aşağıya görselini eklediğim ve dosya olarak linkini verdiğim konuda yardıma ihtiyacım var.
Formüller mevcut hâli ile herhangi bir hata vermiyor. Ancak belirttiğim durumlarda sorun oluyor.

BİLGİ: K3 ve R3 dizi formülü.


We Transfer: https://we.tl/S5aZu4KMEr
Eklenmiş Dosyalar
Dosya Türü: xlsx SIRALAMA.xlsx (18.6 KB, 7 Görüntülenme)

Bu mesaj en son " 17-03-2017 " tarihinde saat 20:34 itibariyle klop01 tarafından düzenlenmiştir....
klop01 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-03-2017, 21:22   #2
numan şamil
Destek Ekibi
 
Giriş: 27/01/2011
Şehir: çorum
Mesaj: 979
Excel Vers. ve Dili:
Ofis 2010 Türkçe
Varsayılan

Merhaba
F3 hücresine;
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(E3="";E3="G");"";TOPLA.ÇARPIM((E3<$E$3:$E$22)/EĞERSAY($E$3:$E$22;$E$3:$E$22&""))+1)
H3 hücresine;
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(E3="";E3="G");"";RANK(E3;$E$3:$E$22)+EĞERSAY($E3:V$3;E3)-1)
Yazıp dener misiniz?
Diğerlerini de buna göre düzenlersiniz veya arkadaşlar yardımcı olur inşaallah

Bu mesaj en son " 17-03-2017 " tarihinde saat 21:39 itibariyle numan şamil tarafından düzenlenmiştir....
numan şamil Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-03-2017, 21:40   #3
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 7,980
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba.

Alternatif.

Belge ekte.
G veya BOŞ ise G yazar, eşitlik halinde listedeki sırası öncelik kriteri olarak kullanılır.
H sütunu sağdaki tablolar için, sıralama kriteri olarak kullanılıyor.
.
Eklenmiş Dosyalar
Dosya Türü: xlsx SIRALAMA2.xlsx (17.9 KB, 2 Görüntülenme)
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-03-2017, 21:58   #4
muygun
Özel Üye
 
muygun kullanıcısının avatarı
 
Giriş: 06/07/2004
Mesaj: 6,466
Excel Vers. ve Dili:
Excel-2003 Türkçe
Varsayılan

Merhaba;
Bir Alternatif daha...
Eki inceleyin.
İyi çalışmalar.
Eklenmiş Dosyalar
Dosya Türü: zip klop01-SIRALAMA.zip (12.3 KB, 8 Görüntülenme)
__________________
Excel-2003 - Türkçe
muygun Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-03-2017, 23:02   #5
klop01
Altın Üye
 
Giriş: 19/12/2016
Şehir: Muğla
Mesaj: 80
Excel Vers. ve Dili:
2016 Türkçe 64 Bit Pro
Varsayılan

Alıntı:
numan şamil tarafından gönderildi Mesajı Görüntüle
Merhaba
F3 hücresine;
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(E3="";E3="G");"";TOPLA.ÇARPIM((E3<$E$3:$E$22)/EĞERSAY($E$3:$E$22;$E$3:$E$22&""))+1)
H3 hücresine;
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(E3="";E3="G");"";RANK(E3;$E$3:$E$22)+EĞERSAY($E3:V$3;E3)-1)
Yazıp dener misiniz?
Diğerlerini de buna göre düzenlersiniz veya arkadaşlar yardımcı olur inşaallah

Sayın numan şamil,
Verdiğiniz formüller bazı hatalı işlemler yaptı.
Sizden sonra belge ekleyen arkadaşlar sorunu büyük oranda halletmişler.
Verdiğiniz emek için teşekkürlerimi belirtmek isterim.
Açıklamalarım geri dönüş yapmak ve bilgi vermek içindir. Tekrar teşekkürler.
klop01 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-03-2017, 23:04   #6
klop01
Altın Üye
 
Giriş: 19/12/2016
Şehir: Muğla
Mesaj: 80
Excel Vers. ve Dili:
2016 Türkçe 64 Bit Pro
Varsayılan

Alıntı:
Ömer BARAN tarafından gönderildi Mesajı Görüntüle
Merhaba.

Alternatif.

Belge ekte.
G veya BOŞ ise G yazar, eşitlik halinde listedeki sırası öncelik kriteri olarak kullanılır.
.
Sayın Ömer Baran,
Yardımınız için teşekkür ederim.
İki durum var:
1. E sütununa G yazınca ve boş bırakınca
F sütununda derece kısmını boş bıraksın veya G yazsın(Sizin formülde derece veriyor.).
2. Siz F sütununda benzersiz sıralama yapan formül kullanmışsınız. F sütununda benzerli sıralama yapan(2 tane yüz olunca ikisine de 1 derecesini verme) formül olabilir mi(G ve boş olunuca 1. maddedeki gibi işleyen)?

BİLGİ TALEBİ: H sütunundaki kısmı anlayamadım. Orası nedir, niçin kullanılıyor?

Bu mesaj en son " 17-03-2017 " tarihinde saat 23:10 itibariyle klop01 tarafından düzenlenmiştir....
klop01 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-03-2017, 23:04   #7
klop01
Altın Üye
 
Giriş: 19/12/2016
Şehir: Muğla
Mesaj: 80
Excel Vers. ve Dili:
2016 Türkçe 64 Bit Pro
Varsayılan

Alıntı:
muygun tarafından gönderildi Mesajı Görüntüle
Merhaba;
Bir Alternatif daha...
Eki inceleyin.
İyi çalışmalar.
Sayın muygun,
Belge için teşekkürler.
Bir konuda değişim yapılabilir mi?
Her iki sıralamada da puan eşitliği durumunda listede yer alan alttaki öğrenciyi önceliyor. Yani liste sırasının tersine işlem yapıyor. Gönderdiğiniz belgedeki 95 alan öğrencilerin durumu konuyu örnekliyor.
Burası düzeltilebilir mi?

F sütununda aynı puan alanlara farklı derece veren(benzersiz) formülü yazılabilir mi?

Bu mesaj en son " 17-03-2017 " tarihinde saat 23:26 itibariyle klop01 tarafından düzenlenmiştir....
klop01 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 18-03-2017, 00:05   #8
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 7,980
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Tekrar merhaba.
Önceki cevabımı ve ekindeki belgeyi yeniledim.
Sayfayı yenileyerek kontrol ediniz.
.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 18-03-2017, 00:34   #9
klop01
Altın Üye
 
Giriş: 19/12/2016
Şehir: Muğla
Mesaj: 80
Excel Vers. ve Dili:
2016 Türkçe 64 Bit Pro
Varsayılan

Alıntı:
Ömer BARAN tarafından gönderildi Mesajı Görüntüle
Tekrar merhaba.
Önceki cevabımı ve ekindeki belgeyi yeniledim.
Sayfayı yenileyerek kontrol ediniz.
.
Tekrar teşekkürler.
Sabrınızı zorlamayacaksa ilk belgedeki benzersiz sıralama yapan =EĞERSAY($H$3:$H$22;">="&H3) formülüne de

E sütununa G yazınca ve E sütununu boş bırakınca F sütununda derece kısmına G yazsın.
özelliği kazandırabilir misiniz?

Hem benzerli hem benzersiz sıralama formülleri birlikte olsun diye.
klop01 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 18-03-2017, 00:49   #10
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 7,980
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

-- F2 hücresine (aşağı doğru kopyalayın)
Bir kez daha söyleyeyim; sağdaki tablolardaki sıralama için H sütunu kullanılıyor, F sütunuyla bir ilgisi yok.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(E3="";E3="G");"G";EĞERSAY($H$3:$H$22;">="&H3))
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 02:15


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Hurda - Torna - Çorlu Web Tasarım - Tarot Falı - Fenerbahçe Haberleri - Trakya Haberleri - Investing - Hurda - Kobi Danışmanlık - Tekirdağ Samsung - Kozmetik Ürünler - Sağlıklı Makyaj Ürünleri - Yaşlanma Karşıtı Ürünler - Excel Eğitimi - Çorlu OSGB - Lingerie - Dyeing Machine - Çorlu Temizlik- Didim Çatı İnşaat
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden