Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 26-08-2015, 16:02   #1
Allback
Altın Üye
 
Giriş: 21/09/2011
Şehir: Kocaeli
Mesaj: 84
Excel Vers. ve Dili:
Excel 2010 - Türkçe
Varsayılan Farklı Sayfalardan Veri Alma

Merhaba,

Çalışmamdaki farklı sayfalarda bulunan verileri tek bir sayfada toplayıp, özet tablo oluşturmak istiyorum.

Normalde (=Sayfaadi!Hücre) yöntemiyle veriler alınabilir ama bendeki durum biraz farklı.

Rapor sayfasının haricinde her güne karşılık gelen 31 sayfa var. (aya göre 30 oluyor) Sayfa adları tarihlerden oluşuyor. (01.08.2015 gibi)

Sayfaları oluştururken, sayfa adlarını belirlediğim bir hücre aralığından alarak makro ile otomatik oluşturuyorum.

Sorum şu: Ay geçişi olduğu zaman, eski sayfalar silinip, yerine yeni sayfalar geliyor (01.09.2015 gibi) Böyle olunca da (=Sayfaadi!Hücre) formülleri hataya dönüşüyor.

Bu nedenle sayfalar yeniden oluşturulduğunda formüllerin tekrar çalışması için nasıl bir formül yazmalıyım.

Sayfa adlarının yazdığı hücre aralığını "Ad Tanımla" kısmından tanımladım. Hatta diğer sayfalardan veri çekmede kullandığım bir formülüm de var. Eski sayfalar silinip yeni sayfalar oluşturulsa bile çalışıyor. Buna benzer bir formül yazmam lazım ama beceremedim.

=TOPLA.ÇARPIM(ETOPLA(DOLAYLI("'"&tarihler&"'!$b$2: $b$200");$B2;DOLAYLI("'"&tarihler&"'!$f$2:$f$200") ))

Örnek dosyada da açıklamamı yaptım. Dosya ile ilgili anlaşılmayan yer olursa seve seve açıklama yapabilirim.
Yardımlarınızı beklerim

http://dosya.web.tr/R6e7rK
Allback Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-08-2015, 16:51   #2
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,052
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

D22:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA.ÇARPIM(ÇOKEĞERSAY(DOLAYLI("'"&tarihler&"'!E2:Z200");$B22
 ;DOLAYLI("'"&tarihler&"'!F2:AA200");D$21))
.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 18:38


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Perde- Çorlu Havuz- Çorlu Havuz- Makina- Danışmazlar- Çorlu Perde Yıkama- Çorlu Perde Yıkama- Okul Danışmanlık- Çorlu Ayakkabı- İzmit Sigorta- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden