Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 23-05-2011, 12:44   #1
ssdestek
 
Giriş: 06/05/2011
Şehir: KOOO
Mesaj: 172
Excel Vers. ve Dili:
TR
Thumbs up Excel Verinin Bulunduğu hücrenin satır numarasını yazdırma

Merhaba,
Bir excel sayfasında A1-A120 arasında DÜŞEYARA() komutu ile veri aratiyorum, aradığım veri hangi satırda bulundu ise verinin bulunduğu satırın satır numarasını C1 hücresine yazsın istiyorum.

ss_örnek.xls ektedir,
saygılarımla,
Eklenmiş Dosyalar
Dosya Türü: xls ss_örnek.xls (39.5 KB, 19 Görüntülenme)

Bu mesaj en son " 23-05-2011 " tarihinde saat 12:45 itibariyle ssdestek tarafından düzenlenmiştir.... Neden: yok
ssdestek Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 12:51   #2
serqet
 
serqet kullanıcısının avatarı
 
Giriş: 19/08/2009
Şehir: Ankara
Mesaj: 520
Excel Vers. ve Dili:
2010 - Türkçe
Varsayılan

düşeyara değilde kaçıncı komutu ile yapabilirsiniz.
serqet Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 13:02   #3
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Şehir: Ankara
Mesaj: 14,341
Excel Vers. ve Dili:
Excel, 2016 - İngilizce
Varsayılan

Alıntı:
ssdestek tarafından gönderildi Mesajı Görüntüle
Merhaba,
Bir excel sayfasında A1-A120 arasında DÜŞEYARA() komutu ile veri aratiyorum, aradığım veri hangi satırda bulundu ise verinin bulunduğu satırın satır numarasını C1 hücresine yazsın istiyorum.

ss_örnek.xls ektedir,
saygılarımla,
.

B1 Hücresinde aranacak isim varsa;

=SUMPRODUCT((A1:A120=C1)*(ROW(A1:A120)))


=TOPLA.ÇARPIM((A1:A120=C1)*(SATIR(A1:A120)))



Not: MATCH=KAÇINCI fonksiyonu ile de bulabiirsiniz.



.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 13:25   #4
serqet
 
serqet kullanıcısının avatarı
 
Giriş: 19/08/2009
Şehir: Ankara
Mesaj: 520
Excel Vers. ve Dili:
2010 - Türkçe
Varsayılan

Alıntı:
yurttas tarafından gönderildi Mesajı Görüntüle
.

B1 Hücresinde aranacak isim varsa;

=SUMPRODUCT((A1:A120=C1)*(ROW(A1:A120)))


=TOPLA.ÇARPIM((A1:A120=C1)*(SATIR(A1:A120)))



Not: MATCH=KAÇINCI fonksiyonu ile bulabilmeniz için isimler alfabetik A-Z veya Z-A sıralı olmalı...


.
Siz daha iyi bilirsiniz üstadım ama ben denedim sorun yok?
Eklenmiş Dosyalar
Dosya Türü: xls Kopya ss_örnek-1.xls (40.0 KB, 26 Görüntülenme)
serqet Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 13:38   #5
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Şehir: Ankara
Mesaj: 14,341
Excel Vers. ve Dili:
Excel, 2016 - İngilizce
Varsayılan

Alıntı:
seqet tarafından gönderildi Mesajı Görüntüle
Siz daha iyi bilirsiniz üstadım ama ben denedim sorun yok?
.

Doğru haklısınız.

Aklımda yanlış kalmış.

Type'ı 0 yazınca oluyormuş.

Düzelttim.

.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 13:39   #6
bogazincocugu
Altın Üye
 
Giriş: 01/06/2009
Şehir: istanbul
Mesaj: 147
Excel Vers. ve Dili:
excel 2003 ve türkçe
Varsayılan

dosyanız ekte
Eklenmiş Dosyalar
Dosya Türü: xls ss_örnek(1).xls (26.0 KB, 32 Görüntülenme)
bogazincocugu Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 15:55   #7
ssdestek
 
Giriş: 06/05/2011
Şehir: KOOO
Mesaj: 172
Excel Vers. ve Dili:
TR
Thumbs up

Alıntı:
seqet tarafından gönderildi Mesajı Görüntüle
Siz daha iyi bilirsiniz üstadım ama ben denedim sorun yok?
--------------------------------------------------------------------------
MERHABA HOCAM, beynine sağlık, proğram çalıştı fakat; B1 hücresine içinde geçen herhangi bir kelime olsa da ara dediğimde bir türlü çalıştıramadım. Yani formülünüzü genişleterek;

=TOPLA.ÇARPIM((A1:A120=BİRLEŞTİR("*";B1;"*"))*(SATIR(A1:A120)))
yazdığımda sıfır veriyor.
Verdiğiniz formülde =TOPLA.ÇARPIM((A1:A120=B1)*(SATIR(A1:A120))) B1 yerine BİRLEŞTİR("*";B1;"*") değeri yazıyorum, yani bu değer B1 hücresinin içinde .....geçen kelime anlamındadır ve sıfır değerini veriyor.
Yardımlarınız için teşekküer ediyorum,

Saygılarımla,
ssdestek Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 16:07   #8
ssdestek
 
Giriş: 06/05/2011
Şehir: KOOO
Mesaj: 172
Excel Vers. ve Dili:
TR
Thumbs up

Alıntı:
yurttas tarafından gönderildi Mesajı Görüntüle
.

B1 Hücresinde aranacak isim varsa;

=SUMPRODUCT((A1:A120=C1)*(ROW(A1:A120)))


=TOPLA.ÇARPIM((A1:A120=C1)*(SATIR(A1:A120)))



Not: MATCH=KAÇINCI fonksiyonu ile de bulabiirsiniz.



.
+++++++++++++++++++++++++++++++++++++++++++++++++
MERHABA HOCAM, beynine sağlık, proğram çalıştı fakat; B1 hücresine içinde geçen herhangi bir kelime olsa da ara dediğimde bir türlü çalıştıramadım. Yani formülünüzü genişleterek;

=TOPLA.ÇARPIM((A1:A120=BİRLEŞTİR("*";B1;"*"))*(SAT IR(A1:A120)))
yazdığımda sıfır veriyor.
Verdiğiniz formülde =TOPLA.ÇARPIM((A1:A120=B1)*(SATIR(A1:A120))) B1 yerine BİRLEŞTİR("*";B1;"*") değeri yazıyorum, yani bu değer B1 hücresinin içinde .....geçen kelime anlamındadır ve sıfır değerini veriyor.
Yardımlarınız için teşekküer ediyorum,

Saygılarımla,
ssdestek Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 16:21   #9
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Şehir: Ankara
Mesaj: 14,341
Excel Vers. ve Dili:
Excel, 2016 - İngilizce
Varsayılan

Alıntı:
ssdestek tarafından gönderildi Mesajı Görüntüle
+++++++++++++++++++++++++++++++++++++++++++++++++
MERHABA HOCAM, beynine sağlık, proğram çalıştı fakat; B1 hücresine içinde geçen herhangi bir kelime olsa da ara dediğimde bir türlü çalıştıramadım. Yani formülünüzü genişleterek;

=TOPLA.ÇARPIM((A1:A120=BİRLEŞTİR("*";B1;"*"))*(SAT IR(A1:A120)))
yazdığımda sıfır veriyor.
Verdiğiniz formülde =TOPLA.ÇARPIM((A1:A120=B1)*(SATIR(A1:A120))) B1 yerine BİRLEŞTİR("*";B1;"*") değeri yazıyorum, yani bu değer B1 hücresinin içinde .....geçen kelime anlamındadır ve sıfır değerini veriyor.
Yardımlarınız için teşekküer ediyorum,

Saygılarımla,
.

=MATCH("*"&B1&"*";A1:A120;0)

=KAÇINCI("*"&B1&"*";A1:A22;0)

şeklinde deneyin.

.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-05-2011, 16:42   #10
ssdestek
 
Giriş: 06/05/2011
Şehir: KOOO
Mesaj: 172
Excel Vers. ve Dili:
TR
Varsayılan

Alıntı:
yurttas tarafından gönderildi Mesajı Görüntüle
.

=MATCH("*"&B1&"*";A1:A120;0)

=KAÇINCI("*"&B1&"*";A1:A22;0)

şeklinde deneyin.

.
************************************************** ***
Teşekkür ederim, soruma cevap aldım, çalıştı.

Saygılarımla,
ssdestek Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 02:21


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden