Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 06-11-2013, 22:30   #1
m_murat
 
Giriş: 13/05/2008
Şehir: Mardin
Mesaj: 8
Excel Vers. ve Dili:
2010 Türkçe
Varsayılan Eğer fonksiyonu

Değerli arkadaşlar ben şunu yapmak istiyorum bana yardımcı olabilir misiniz.
A6 hücresinde "R" olsun ve A7:A11 hücreleri boş olsun ben diyorum ki eğer A7:A11 dolu ise ve A6="R" ise A7:A11 toplasın ve 1 sayı çıkarsın değilse sadece toplasın.
m_murat Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-11-2013, 14:18   #2
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,013
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

Dolu olma şartında, sadece biri dolu olursa diye anladım.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA(A7:A11)-VE(A6="R";EĞERSAY(A7:A11;"<>")<>0)
.
__________________
.
Ömer Çevrimiçi   Alıntı Yaparak Cevapla
Eski 10-11-2013, 18:03   #3
m_murat
 
Giriş: 13/05/2008
Şehir: Mardin
Mesaj: 8
Excel Vers. ve Dili:
2010 Türkçe
Varsayılan

Çok teşekkür ederim. İstediğim cevaptı.
m_murat Çevrimdışı   Alıntı Yaparak Cevapla
Eski 10-11-2013, 22:42   #4
kamenzü
 
Giriş: 20/12/2006
Şehir: Ankara
Mesaj: 173
Excel Vers. ve Dili:
365 (2016) Türkçe
Varsayılan

Yanlış anladıysam özür dilerim ancak;

=EĞER(VE(A6="R";EĞERSAY(A7:A11;"<>")>0);(TOPLA(A7: A11))-1;TOPLA(A7:A11))

olması lazım değil mi???

r yazıyorsa ve aralık doluysa toplayıp 1 çıkarıyor.

aksi durumda sadece topluyor.
kamenzü Çevrimdışı   Alıntı Yaparak Cevapla
Eski 11-11-2013, 09:37   #5
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,013
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

Doğru anladınız. Yalnız 2 formülde aynı işlemi yapar.

=TOPLA(A7:A11)-VE(A6="R";EĞERSAY(A7:A11;"<>")<>0)

Kırmızı işaretli değer şartları sağlarsa DOĞRU yani 1, sağlamazsa YANLIŞ yani 0 değerini üretir. Mantığı aynı olduğu için eğer kullanmadan sadece formülü kısalttım.
__________________
.
Ömer Çevrimiçi   Alıntı Yaparak Cevapla
Eski 11-11-2013, 14:46   #6
bycray
 
Giriş: 27/11/2012
Şehir: ordu
Mesaj: 2
Excel Vers. ve Dili:
2003,2010
Varsayılan

Peki bu formül iş görebilir mi ?

=EĞER(A6="R";TOPLA(A7:A11)-1;TOPLA(A7:A11))
bycray Çevrimdışı   Alıntı Yaparak Cevapla
Eski 11-11-2013, 20:19   #7
m_murat
 
Giriş: 13/05/2008
Şehir: Mardin
Mesaj: 8
Excel Vers. ve Dili:
2010 Türkçe
Varsayılan

Arkadaşlar Merhaba,
A1:A5 arası toplar ve toplamı 10 nun altındaysa 0, 20 nin altındaysa 1, 30 un altındaysa 2, 40 ın altındaysa 3 değerini versin. Şimdiden teşekkürler.
m_murat Çevrimdışı   Alıntı Yaparak Cevapla
Eski 11-11-2013, 21:25   #8
Mahir ÇÜMEN
Destek Ekibi
 
Mahir ÇÜMEN kullanıcısının avatarı
 
Giriş: 19/04/2006
Şehir: UŞAK
Mesaj: 5,060
Excel Vers. ve Dili:
Excel 2013-Türkçe
Varsayılan

Merhaba,

40'ın altındaysa 3 değeri verilsin demişsiniz, peki 40'ın üzerinde olduğunda ne değeri verilecek?
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(TOPLA(A1:A5)<10;0;EĞER(TOPLA(A1:A5)<20;1;EĞER(TOPLA(A1:A5)<30;2;EĞER(TOPLA(A1:A5)<40;3;""))))
__________________
Türkçenin bir eksiği yok, ya sizin?

Bir yalan, hangi amaç için söylenmiş olursa olsun, her zaman, en kötü gerçekten daha kötüdür.Che Guevara
Mahir ÇÜMEN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-11-2013, 19:40   #9
m_murat
 
Giriş: 13/05/2008
Şehir: Mardin
Mesaj: 8
Excel Vers. ve Dili:
2010 Türkçe
Varsayılan

Mahir Bey,
Çok Teşekkürler. 40 üstü bana lazım değildi. çok sağol.
m_murat Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-11-2013, 19:43   #10
m_murat
 
Giriş: 13/05/2008
Şehir: Mardin
Mesaj: 8
Excel Vers. ve Dili:
2010 Türkçe
Varsayılan

excellde "dolu ise" nasıl yazılır.
birde excellde kullanlan simge ve işaretler nelerdir anlamları nedir. Şimdiden tşk.
m_murat Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 14:58


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri- Çorlu Çelik Konstruksiyon-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden