Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 16-11-2017, 10:48   #1
ATEMİ
 
Giriş: 09/01/2006
Şehir: istanbul bayrampaþa
Mesaj: 90
Varsayılan Değerlerden birinin sıfır olması halinde oran hata veriyor (#SAYI/0!)

Merhaba Arkadaşlar;
Sorunumu şöyle anlatmaya çalışacağım;
A1 hücresi ile B1 hücresi arasındaki fark tutarı pozitif çıkarsa C1 oranıda D1 e atmalı negatif tutar E1 negatif oranıda F1 hücresine atsın istiyorum
Yani
a-) 100 (A1) 140 (B1) 40 (C1) %40 (D1) 0 (E1) %0 (F1) 40 TL tutarında %40 lık artış var

b-) 200 (A1) 120 (B1) 0 (C1) %0 (D1) 80 (E1) %60 (F1) 80 TL tutarında %60 lık düşüş var

c-) 0 (A1) 90 (B1) 90 (C1) %90 (D1) 0 (E1) %0 (F1) 90 TL tutarında %90 lık artış var

burda problem c şıkkındaki oransal değerlerde a veya b şıkkı 0 olduğunda D ve F sütunu #SAYI/0! hatası veriyor

Benim istediğim değerlerden biri sıfır olsa bile pozitif sonuçta D sütunu oranını verirken F sütunu boş çıksın
Aynı şekilde değerlerden biri sıfır olsa bile negatif sonuçta ad D sütununu boş verirken F sütununda da oranı çıksın
her 2 değer de sıfır ise hücreler boş çıksın Teşekkür ederim
__________________
office2003 türkçe
ATEMİ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 12:05   #2
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,031
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

Tablonuzun formüllü halinin küçük bir örneğini ekler misiniz.

www.dosya.tc

.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 12:28   #3
ATEMİ
 
Giriş: 09/01/2006
Şehir: istanbul bayrampaþa
Mesaj: 90
Varsayılan

Eğer(d4<ı4;"";ı4/d4)
eğer(d4>ı4;"";d4/ı4)
__________________
office2003 türkçe
ATEMİ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 12:31   #4
ATEMİ
 
Giriş: 09/01/2006
Şehir: istanbul bayrampaþa
Mesaj: 90
Varsayılan

Ömer bey özür dilerim hızlı cevap yazdım formülü istiyorsunuz sandım kabaca tablo hazırlayıp hemen yolluyorum
__________________
office2003 türkçe
ATEMİ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 12:36   #5
KarıncaZ
 
KarıncaZ kullanıcısının avatarı
 
Giriş: 22/01/2006
Şehir: KOCAELİ
Mesaj: 207
Excel Vers. ve Dili:
Office 2003 , 2013 ve 2016 TR.
Varsayılan

Merhaba

Ekli dosya işinizi görür sanırım.
İlk satırda başlıkların olduğunu varsayarak
C2 : =EĞER(A2=0;(B2/100);EĞER(B2=0;(A2/100);EĞER(A2<B2;((B2-A2)/A2);EĞER(B2<A2;((A2-B2)/A2);0))))

D2 : =B2-A2

E2 : =METNEÇEVİR(MUTLAK(D2);"#.##0,00")&"-TL. Tutarında "&METNEÇEVİR(C2;"0%")&" oranında"&EĞER(B2>A2;"Artış";EĞER(A2>B2;"Azalış";" Değişim Yok"))

Formüllerini yazın.

Örnek dosya aşağıdaki linkte

http://s5.dosya.tc/server5/tx5vk2/Ornek.xlsx.html

.
__________________
Excel 2003 - 2007 - 2010 - 2013 - 2016 Türkçe
KarıncaZ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 12:52   #6
ATEMİ
 
Giriş: 09/01/2006
Şehir: istanbul bayrampaþa
Mesaj: 90
Varsayılan

http://www.dosya.tc/server10/ixu0zb/...rmul.xlsx.html
umarım olmuştur
__________________
office2003 türkçe
ATEMİ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 13:01   #7
parametre
Destek Ekibi
 
Giriş: 28/01/2007
Mesaj: 1,542
Excel Vers. ve Dili:
ofis 2010 turkce
Varsayılan

ilgili bolume formulu kopyalarsanız sorununuz çozulecektir.Kolay gelsin
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=eğer(ve(d4<>0;I4<>0);Eğer(d4<I4;I4/d4;
eğer(d4>I4;d4/I4;0)))
parametre Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 13:04   #8
ATEMİ
 
Giriş: 09/01/2006
Şehir: istanbul bayrampaþa
Mesaj: 90
Varsayılan

Sayın karınca emeğinize sağlık ancak benim anlatımımla alakalı sorun var az önce tabloyu ekledim bir inceleyebilir misiniz
__________________
office2003 türkçe
ATEMİ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 13:21   #9
KarıncaZ
 
KarıncaZ kullanıcısının avatarı
 
Giriş: 22/01/2006
Şehir: KOCAELİ
Mesaj: 207
Excel Vers. ve Dili:
Office 2003 , 2013 ve 2016 TR.
Varsayılan

Kaynak (-) lere düşüş olursa veri geliyor.

Kullanım (+) lara artış olursa veri geliyor.


G4 : =EĞER(E4>=D4;0;MUTLAK(D4-E4))

H4 : =EĞER(E4>=D4;0;MUTLAK(D4-E4)/D4)

I4 : =EĞER(E4<=D4;0;MUTLAK(D4-E4))

J4 : =EĞER(D4=0;E4/100;EĞER(E4<=D4;0;MUTLAK(D4-E4)/D4))

Hesaplamalarda yaşadığınız sorun temel matematik kuralı ; Sıfırın herhangi bir sayıya bölünmesi tanımsız.

Esenlikler dilerim. İyi çalışmalar.
__________________
Excel 2003 - 2007 - 2010 - 2013 - 2016 Türkçe

Bu mesaj en son " 16-11-2017 " tarihinde saat 13:28 itibariyle KarıncaZ tarafından düzenlenmiştir.... Neden: Açıklama ekleme ve formül düzeltme
KarıncaZ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-11-2017, 13:56   #10
ATEMİ
 
Giriş: 09/01/2006
Şehir: istanbul bayrampaþa
Mesaj: 90
Varsayılan

Sayın karınca teşekkür ediyorum işimi görecek bu yaptığınız kaynak ve kullanım sütunlarının içinde sıfırların boş olarak görülmesi sağlanamaz mı?
Bir de D4 e 0 yazdığımda J4 %243978,0098 çıkması ciddi problem mesela E4 e sıfır yazdığımda H4 tam istediğim gibi %100 çıkıyor
__________________
office2003 türkçe
ATEMİ Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 22:20


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri- Çorlu Çelik Konstruksiyon- Çorlu Dans- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden