Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 12-10-2017, 13:02   #1
b_arisoy
 
Giriş: 25/08/2006
Mesaj: 20
Varsayılan Dakikadan dakika çıkarma

İyi günler,
Dakika ve saniye cinsi bir süreden yine dakika ve saniye çıkartmak istiyorum.
Bundaki amaç çalışanın ay içinde ne kadar eksik veya fazla süre çalıştığını hesaplayabilmek.

Şöyle ki;

A1=138:45 (Bir ay içinde çalışılan süre)
A2: 170:00 (Bir ay içinde çalışılması gereken süre)

138:45 - 170:00 = ? (138 dakika 45 saniye - 170 dakika 00 saniye = ?)

A1'in A2'den büyük olduğu durumlarda hesaplamayı =EĞER(A1>A2;"+"&METNEÇEVİR(A1-A2;"[ss]:dd");A1-A2) formülü ile yapabiliyorum ancak ilk süre diğerinden kısa olduğu zaman bu formül çalışmıyor.

Yardımcı olabilirseniz sevinirim. Teşekkürler.
b_arisoy Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-10-2017, 13:10   #2
lktss
Altın Üye
 
Giriş: 05/10/2017
Şehir: Afyonkarahisar
Mesaj: 14
Excel Vers. ve Dili:
MS Excel 2007 Türkçe
Varsayılan

Sn. b_arisoy

Her iki durum için de kullanılabilir;

=EĞER(A1>A2;"+"&METNEÇEVİR(A1-A2;"[ss]:dd");"+"&METNEÇEVİR(A2-A1;"[ss]:dd")) formülünü dener misiniz?
lktss Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-10-2017, 13:12   #3
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereğli
Mesaj: 711
Varsayılan

Hücre biçimini tüm sayı biçimleri ,isteğe uyarlanmış tür kısmına [dd] yazın dakika olarak çıkarma yapabilirsiniz [s] yazarsanız saat olarak çıkar.
çıtır Çevrimiçi   Alıntı Yaparak Cevapla
Eski 12-10-2017, 13:17   #4
b_arisoy
 
Giriş: 25/08/2006
Mesaj: 20
Varsayılan

Alıntı:
lktss tarafından gönderildi Mesajı Görüntüle
Sn. b_arisoy

Her iki durum için de kullanılabilir;

=EĞER(A1>A2;"+"&METNEÇEVİR(A1-A2;"[ss]:dd");"+"&METNEÇEVİR(A2-A1;"[ss]:dd")) formülünü dener misiniz?
Maalesef çalışmadı. Bu formülde de ilk süre büyükse hesaplama yapıyor.
b_arisoy Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-10-2017, 13:20   #5
1Al2Ver
Altın Üye
 
1Al2Ver kullanıcısının avatarı
 
Giriş: 05/11/2007
Şehir: İstanbul / Maltepe
Mesaj: 3,602
Excel Vers. ve Dili:
Microsoft Office 365 ProPlus
Varsayılan

Merhaba,

Deneyiniz , Değer eksi ise de hücreye yazar, eşitse sıfır yazar. Örneğinize göre sonuç : -31:15 çıkıyor.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(A2>A1;"-"&METNEÇEVİR(A2-A1;"[ss]:dd");EĞER(A1>A2;"+"&METNEÇEVİR(A1-A2;"[ss]:dd")*0;))
__________________
Esen Kalın...
1Al2Ver Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-10-2017, 13:25   #6
b_arisoy
 
Giriş: 25/08/2006
Mesaj: 20
Varsayılan

Alıntı:
çıtır tarafından gönderildi Mesajı Görüntüle
Hücre biçimini tüm sayı biçimleri ,isteğe uyarlanmış tür kısmına [dd] yazın dakika olarak çıkarma yapabilirsiniz [s] yazarsanız saat olarak çıkar.
Bu şekilde yapınca sonuncu -1875 olarak veriyor. Dakika saniye şeklinde ayırmaya çalıştım ama yine olmadı. ################ olarak gösteriyor.
b_arisoy Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-10-2017, 13:28   #7
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereğli
Mesaj: 711
Varsayılan

[s]:dd Şeklinde yazın saat ve dakika olarak sonuçu verir.Formül de
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
 =EĞER((A1-A2)<0;(A1-A2)*-1;(A1-A2))

Bu mesaj en son " 12-10-2017 " tarihinde saat 13:34 itibariyle çıtır tarafından düzenlenmiştir....
çıtır Çevrimiçi   Alıntı Yaparak Cevapla
Eski 12-10-2017, 14:35   #8
b_arisoy
 
Giriş: 25/08/2006
Mesaj: 20
Varsayılan

Alıntı:
çıtır tarafından gönderildi Mesajı Görüntüle
[s]:dd Şeklinde yazın saat ve dakika olarak sonuçu verir.Formül de
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
 =EĞER((A1-A2)<0;(A1-A2)*-1;(A1-A2))
Teşekkürler.
b_arisoy Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-10-2017, 14:36   #9
b_arisoy
 
Giriş: 25/08/2006
Mesaj: 20
Varsayılan

Teşekkürler.
b_arisoy Çevrimdışı   Alıntı Yaparak Cevapla
Eski 12-10-2017, 14:37   #10
b_arisoy
 
Giriş: 25/08/2006
Mesaj: 20
Varsayılan

Alıntı:
1Al2Ver tarafından gönderildi Mesajı Görüntüle
Merhaba,

Deneyiniz , Değer eksi ise de hücreye yazar, eşitse sıfır yazar. Örneğinize göre sonuç : -31:15 çıkıyor.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(A2>A1;"-"&METNEÇEVİR(A2-A1;"[ss]:dd");EĞER(A1>A2;"+"&METNEÇEVİR(A1-A2;"[ss]:dd")*0;))
Teşekkürler.
b_arisoy Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 22:41


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Torna - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Çorlu Temizlik- Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Su Deposu Temizliği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden