Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 25-03-2017, 11:13   #1
Cihan SK
Altın Üye
 
Giriş: 20/01/2017
Şehir: Antalya,Muratpaşa
Mesaj: 87
Excel Vers. ve Dili:
Microsoft Excel 2013
Varsayılan İç içe eğer formülü

Merhaba arkadaşlar,

içinden çıkamadığım bir durum var.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=+EĞER(YADA(VE(A2>="100";A2<"300");EĞER(I2>=0;"DOĞRU";"KONTROL ET"));EĞER(A2>="300";A2<"600");EĞER(I2<=0;"DOĞRU";"KONTROL ET"))
Bu formülü çalıştıramadım.

Açıklaması şu :
100 - 300 aralığında 100 dahil 300 değil = I2 hücresi 0 eşit ya da 0 büyükse doğru değilse yanlış ve 300 - 600 aralığında 300 dahil 600 değil = I2 hücresi 0 eşit ya da 0 küçükse doğru değilse yanlış ve 600 - 900 aralığında 600 dahil 900 değil = I2 hücresi 0 eşit ya da 0 büyükse doğru değilse yanlış şeklinde bir kombinasyona ihtiyacım var.

Yardımcı olacak arkadaşlar teşekkür ediyorum.
Cihan SK Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-03-2017, 12:48   #2
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 18,999
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

Açıklamaya göre 3 şart da birbirine bağlantılı, bu yüzden aşağıdaki formül yeterli olur.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(VE(A2>=100;A2<900;ESAYIYSA(I2));"DOĞRU";"KONTROL ET")
.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-03-2017, 13:09   #3
Cihan SK
Altın Üye
 
Giriş: 20/01/2017
Şehir: Antalya,Muratpaşa
Mesaj: 87
Excel Vers. ve Dili:
Microsoft Excel 2013
Varsayılan

[quote=Ömer;887231]Merhaba,

Açıklamaya göre 3 şart da birbirine bağlantılı, bu yüzden aşağıdaki formül yeterli olur.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(VE(A2>=100;A2<900;ESAYIYSA(I2));"DOĞRU";"KONTROL ET")

Şöyle bir sıkıntı var. Belki ben yanlış anlatmış olabilirim. Bu bahsetmiş olduğum formül, Tekdüzen hesap planı için gerekli buradaki amaç hesap kodlarım, 100 - 300 arasında ise I2 hücremdeki veri sıfır ya da sıfırdan büyük olmak zorunda negatif olursa kontrol et. 300 - 600 hesap arasındaki I2 hücremdeki veri sıfıra eşit ya da sıfırdan küçük olmalı değilse kontrol et 600 - 900 hesap kodunda I2 hücrem sıfıra eşit ve sıfırdan büyük olmalı eğer küçükse kontrol et olmalı.

Kısaca A sütunundaki hesap aralığına göre I hücresindeki bulunan sayının -+ ve 0 eşit olması halinde hesap terste mi değil mi uygulama amacı bu.
Cihan SK Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-03-2017, 13:16   #4
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 18,999
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Bu şekilde deneyin.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(VE(A2>=100;A2<300;I2>=0);VE(A2>=600;A2<900;I2>=0);VE(A2>=300;A2<600;I2<=0));"DOĞRU";"KONTROL ET")
.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-03-2017, 13:17   #5
KarıncaZ
 
KarıncaZ kullanıcısının avatarı
 
Giriş: 22/01/2006
Şehir: KOCAELİ
Mesaj: 206
Excel Vers. ve Dili:
Office 2003 , 2013 ve 2016 TR.
Varsayılan ...

Merhaba

=EĞER(VE(A2>=100;A2<300;I2>=0);"Doğru";EĞER(VE(A2> =300;A2<600;I2>=0);"Doğru";EĞER(VE(A2>=600;A2<900; I2>=0);"Doğru";"Yanlış")))

Anladığım kadarıyla yaptım, bi deneyin isterseniz.

.
__________________
Excel 2003 - 2007 - 2010 - 2013 - 2016 Türkçe
KarıncaZ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-03-2017, 14:08   #6
Cihan SK
Altın Üye
 
Giriş: 20/01/2017
Şehir: Antalya,Muratpaşa
Mesaj: 87
Excel Vers. ve Dili:
Microsoft Excel 2013
Varsayılan

Alıntı:
Ömer tarafından gönderildi Mesajı Görüntüle
Bu şekilde deneyin.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(VE(A2>=100;A2<300;I2>=0);VE(A2>=600;A2<900;I2>=0);VE(A2>=300;A2<600;I2<=0));"DOĞRU";"KONTROL ET")
.
Ömer bey ve Karıncaz Bey yardımlarınız için size çok teşekkür ediyorum. iki formülde çalışıyor. Ancak sayıları tırnak içine alınca doğru sonuca ulaştım.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(YADA(VE(A2>="100";A2<"300";J2>=0);VE(A2>="600";A2<"900";J2>=0);VE(A2>="300";A2<"600";J2<=0));"DOĞRU";"KONTROL ET")
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=+EĞER(VE(A2>=100;A2<300;I2>=0);"Doğru";EĞER(VE(A2>300;A2<600;I2>=0);"Doğru";EĞER(VE(A2>=600;A2<900;I2>=0);"Doğru";"Yanlış")))
Cihan SK Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-03-2017, 22:27   #7
KarıncaZ
 
KarıncaZ kullanıcısının avatarı
 
Giriş: 22/01/2006
Şehir: KOCAELİ
Mesaj: 206
Excel Vers. ve Dili:
Office 2003 , 2013 ve 2016 TR.
Varsayılan ...

Doğru sonuca ulaştıysanız mesele yok.

Sayı değerlerinin olduğu hücre Metin formatında olduğu içindir muhtemelen. Metin olan değerler " " arasına yazılıyor. Bu nedenle sayı değerlerinin yazılabileceği tüm hücreleri aynı formatta olmasına dikkat edin. Formüller bazı satırlarda çalışırken bazı satırlarda çalışmaya bilir.

Esenlikler dilerim. İyi çalışmalar.

.
__________________
Excel 2003 - 2007 - 2010 - 2013 - 2016 Türkçe
KarıncaZ Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-03-2017, 16:12   #8
muazzamhus
 
Giriş: 22/03/2017
Şehir: BURSA
Mesaj: 7
Excel Vers. ve Dili:
EXCEL 2016, Türkçe
Varsayılan

Alıntı:
KarıncaZ tarafından gönderildi Mesajı Görüntüle
Doğru sonuca ulaştıysanız mesele yok.

Sayı değerlerinin olduğu hücre Metin formatında olduğu içindir muhtemelen. Metin olan değerler " " arasına yazılıyor. Bu nedenle sayı değerlerinin yazılabileceği tüm hücreleri aynı formatta olmasına dikkat edin. Formüller bazı satırlarda çalışırken bazı satırlarda çalışmaya bilir.

Esenlikler dilerim. İyi çalışmalar.

.

Teşekkürler. Çalıştı.
Hepiniz var olun.
muazzamhus Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-10-2017, 16:22   #9
mdemirel_03
Altın Üye
 
Giriş: 07/10/2017
Şehir: afyon
Mesaj: 4
Excel Vers. ve Dili:
2010
Varsayılan

Merhabalar;

Ekteki dosyada koli başı prim hesaplamak istiyorum,kırmızı ve yeşil olarak ayırdığım kategoriler var. Kırmızılarda herhangi bir şart yok sadece hedefi gerçekleştirme yeterli. Yeşillerin herhangi birinden prim alması için kırmızıların en az birinin hedefi gerçekleşmesi gerekiyor. Kırmızılar hedefi gerçekleştiremezse yeşiller gerçekleştirse bile hesaplanmayacak. Biraz uğraştım ama sonuca ulaşamadım. Yardımcı olursanız sevinirim.
Eklenmiş Dosyalar
Dosya Türü: xlsx KOLİ BAŞI PRİM HESAPLAMA.xlsx (11.8 KB, 14 Görüntülenme)
mdemirel_03 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 27-10-2017, 15:55   #10
mdemirel_03
Altın Üye
 
Giriş: 07/10/2017
Şehir: afyon
Mesaj: 4
Excel Vers. ve Dili:
2010
Varsayılan Eğer formülü

Alıntı:
mdemirel_03 tarafından gönderildi Mesajı Görüntüle
Merhabalar;

Ekteki dosyada koli başı prim hesaplamak istiyorum,kırmızı ve yeşil olarak ayırdığım kategoriler var. Kırmızılarda herhangi bir şart yok sadece hedefi gerçekleştirme yeterli. Yeşillerin herhangi birinden prim alması için kırmızıların en az birinin hedefi gerçekleşmesi gerekiyor. Kırmızılar hedefi gerçekleştiremezse yeşiller gerçekleştirse bile hesaplanmayacak. Biraz uğraştım ama sonuca ulaşamadım. Yardımcı olursanız sevinirim.
Arkadaşlar yardım edecek kimse yok mu ?
mdemirel_03 Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 17:27


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden