Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 29-10-2017, 07:20   #1
cimcoz
Altın Üye
 
cimcoz kullanıcısının avatarı
 
Giriş: 06/10/2004
Şehir: ISTANBUL
Mesaj: 118
Excel Vers. ve Dili:
MS Office Plus 2010 Eng - Win XP MS Office Plus 2016 Eng - Mac OSX
Varsayılan Üç Hücredeki veriye göre listeleme

Merhaba,

Hediye paketleri listemde, B4,C4 ve D4 hücrelerindeki değeri sağlayan 4.ve 5.(E4 ve F4) hücredeki değerlerin listesini yazdırmak istiyorum.

Yani I4, J4 ve K4 hücrelerine yazdığım 3 ürünü (sıralı olması lazım) sağlayan ürünlere göre M4 ve N4'e liste çıkarmak istiyorum.

Örnek dosya ektedir.

Yardımlarınız için şimdiden teşekkür ederim.

Saygılarımla,
Eklenmiş Dosyalar
Dosya Türü: xlsx listeleme.xlsx (12.3 KB, 16 Görüntülenme)

Bu mesaj en son " 29-10-2017 " tarihinde saat 11:23 itibariyle cimcoz tarafından düzenlenmiştir.... Neden: Dosya yükleme
cimcoz Çevrimdışı   Alıntı Yaparak Cevapla
Eski 29-10-2017, 10:41   #2
Emir Hüseyin Çoban
Destek Ekibi
 
Emir Hüseyin Çoban kullanıcısının avatarı
 
Giriş: 11/08/2008
Şehir: Denizli
Mesaj: 5,675
Excel Vers. ve Dili:
Office 2013 Tr - Win8 x64
Varsayılan

. . .

Altın üyesiniz dosyanızı forumada yükleyebilirsiniz.

Virüs programlarının güvenlik seviyesinden dolayı bir çok dosya yükleme sitesinde uyarı verir. Tıpkı şuanda benim bilgisayarımda (eset) olduğu gibi..

. . .
__________________
.
Cüzzi Ücretlerle Sorularınıza Özel Destek Almak İçin Özel Mesaj Yazabilirsiniz...

e-mail: huseyincobann@gmail.com
Tel: 0531-285-06-15

http://www.excel.web.tr/private.php?do=newpm&u=101759

Örnek Dosya Hazırlarken Dikkat Edilmesi Gerekenler için link:
https://goo.gl/ckn2NC
_

İyi Günler...

Türkçe konuşup, Excel'ce yazıyoruz!..
...:::: Diren #Excel.Web.Tr :::....


Emir Hüseyin Çoban Çevrimdışı   Alıntı Yaparak Cevapla
Eski 29-10-2017, 11:24   #3
cimcoz
Altın Üye
 
cimcoz kullanıcısının avatarı
 
Giriş: 06/10/2004
Şehir: ISTANBUL
Mesaj: 118
Excel Vers. ve Dili:
MS Office Plus 2010 Eng - Win XP MS Office Plus 2016 Eng - Mac OSX
Varsayılan

Yeni üye olmuştum.

Örnek buraya dosyayı yükledim.

Teşekkürler.
cimcoz Çevrimdışı   Alıntı Yaparak Cevapla
Eski 29-10-2017, 12:07   #4
Ziynettin
Altın Üye
 
Giriş: 17/04/2008
Şehir: istanbul
Mesaj: 393
Excel Vers. ve Dili:
office2010
Varsayılan

Merhaba,

M4
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(SATIRSAY($1:1)<=TOPLA.ÇARPIM(($B$4:$B$18=$I$4)*($C$4:$C$18=$J$4)*($D$4:$D$18=$K$4));İNDİS($E$4:$E$18;KÜÇÜK(EĞER(($B$4:$B$18=$I$4)*($C$4:$C$18=$J$4)*($D$4:$D$18=$K$4);SATIR(DOLAYLI("1:"&SATIRSAY($B$4:$B$18))));SATIRSAY($1:1)));"")
N4
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(SATIRSAY($1:1)<=TOPLA.ÇARPIM(($B$4:$B$18=$I$4)*($C$4:$C$18=$J$4)*($D$4:$D$18=$K$4));İNDİS($F$4:$F$18;KÜÇÜK(EĞER(($B$4:$B$18=$I$4)*($C$4:$C$18=$J$4)*($D$4:$D$18=$K$4);SATIR(DOLAYLI("1:"&SATIRSAY($B$4:$B$18))));SATIRSAY($1:1)));"")
Dizi formulu. Ctrl+Shift+Enter
Ziynettin Çevrimdışı   Alıntı Yaparak Cevapla
Eski 29-10-2017, 12:34   #5
antonio
Destek Ekibi
 
antonio kullanıcısının avatarı
 
Giriş: 13/02/2011
Mesaj: 1,031
Excel Vers. ve Dili:
Excel 2013
Varsayılan

Alternatif olarak;
Makro ile aşağıdaki kodları deneyebilirsiniz.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
Sub listele_sirala()
Dim sh As Worksheet, ss As Long, a1 As Range, a2 As Range

Set sh = Sheets(Sheets(1).Name)
ss = sh.Range("C" & Rows.Count).End(3).Row

Set a1 = sh.Range("B2:D" & ss)
Set a2 = sh.Range("E2:F" & ss)
sat1 = a1.Rows.Count
sut1 = a1.Columns.Count

sat2 = a2.Rows.Count
sut2 = a2.Columns.Count
sh.Range("I3:K56789").ClearContents
sh.Range("M3:N56789").ClearContents

sh.Range("I2").Resize(sat1, sut1).Value = a1.Value
sh.Range("M2").Resize(sat2, sut2).Value = a2.Value

MsgBox "İşlem tamamlandı", vbInformation, "antonio"
Set sh = Nothing
Set a1 = Nothing
Set a2 = Nothing
End Sub
__________________
Özel mesaj sistemini devre dışı bıraktım.
Yardım istemeden önce Forum Kurallarını okuyunuz.
Aynı konuyu farklı bölümlerde açanların sorularını yanıtlamıyorum, bu durumu fark etmeden yanıtlamışsam, mesajımı siliyorum.
antonio Çevrimdışı   Alıntı Yaparak Cevapla
Eski 30-10-2017, 11:54   #6
cimcoz
Altın Üye
 
cimcoz kullanıcısının avatarı
 
Giriş: 06/10/2004
Şehir: ISTANBUL
Mesaj: 118
Excel Vers. ve Dili:
MS Office Plus 2010 Eng - Win XP MS Office Plus 2016 Eng - Mac OSX
Varsayılan

Sayın Ziynettin ve Antonia Bey,

Yardımlarınız için çok teşekkür ederim. Ellerinize sağlık..

Saygılar,
cimcoz Çevrimdışı   Alıntı Yaparak Cevapla
Eski 30-10-2017, 12:41   #7
kuvari
Destek Ekibi
 
kuvari kullanıcısının avatarı
 
Giriş: 04/05/2007
Şehir: İstanbul
Mesaj: 2,633
Excel Vers. ve Dili:
OFİS 2013 TÜRKÇE-İNG. 64 BİT
Varsayılan

Merhaba,

Aşağıdaki dizi formülünüde alternatif olarak kullanabilirsiniz.

M4 hücresine uygulayın.Yana ve aşağıya doğru kopyalayın.
Dizi formülüdür. CTRL+SHIFT+ENTER ile kapatmayı unutmayın.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞERHATA(İNDİS(E$4:E$18;KÜÇÜK(EĞER($B$4:$B$18&$C$4:$C$18&$D$4:$D$18=$I$4&$J$4&$K$4;SATIR($4:$18);"");SATIR(A1))-3);"")
__________________
Bilgi kadar zenginlik, cehalet kadar yoksulluk yoktur.
(Hz. Ali)
kuvari Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 06:36


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden