Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 08-10-2017, 13:11   #1
cimcoz
 
cimcoz kullanıcısının avatarı
 
Giriş: 06/10/2004
Şehir: ISTANBUL
Mesaj: 103
Excel Vers. ve Dili:
2003 & 2007 İngilizce
Varsayılan 2 Farklı sütündaki değerlere göre, 3. Sütundaki Değeri Saymak

Merhaba,

A,B sütunlarındaki "Elma" değerini dikey aratıp, bulduğu "Elma" kelimesinin , C sütunu hizasındaki hücrelerde bulunan "Yeşil" veya "Kırmızı" kelimeleri saymasını istiyorum.(Kırmızı ve Yeşil kelimelerini C sütunundan aratmam lazım)

Taslak Olarak

A B C
Elma Armut Kırmızı
Kiraz Elma Yeşil
Armut Kavun Kırmızı
Kiraz Karpuz Yeşil
Karpuz Elma Yeşil
Elma Kiraz Yeşil
Elma Karpuz Kırmızı

Bu tabloya göre sonucu:

Elma Sayıları:
Yeşil : 3
Kırmızı : 2

olarak çıkaran bir formül veya makroya ihtiyacım.

Yardımlarınız için şimdiden teşekkür eder, iyi haftasonları dilerim.

Saygılarımla,
cimcoz Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-10-2017, 13:28   #2
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereğli
Mesaj: 720
Varsayılan

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=ÇOKEĞERSAY(A2:A10;"Elma";C2:C10;"Yeşil")+ÇOKEĞERSAY(B2:B10;"Elma";C2:C10;"Yeşil")
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=ÇOKEĞERSAY(A2:A10;"Elma";C2:C10;"Kırmızı")+ÇOKEĞERSAY(B2:B10;"Elma";C2:C10;"Kırmızı")
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA.ÇARPIM(--($A$2:$B$8="Elma")*(C$2:$C$8="Kırmızı"))
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA.ÇARPIM(--($A$2:$B$8="Elma")*(C$2:$C$8="Yeşil"))

Bu mesaj en son " 08-10-2017 " tarihinde saat 13:34 itibariyle çıtır tarafından düzenlenmiştir....
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-10-2017, 14:14   #3
cimcoz
 
cimcoz kullanıcısının avatarı
 
Giriş: 06/10/2004
Şehir: ISTANBUL
Mesaj: 103
Excel Vers. ve Dili:
2003 & 2007 İngilizce
Varsayılan

Elinize sağlık. Çok teşekkür ederim, tam istediğim de buydu.
cimcoz Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-10-2017, 14:27   #4
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereğli
Mesaj: 720
Varsayılan

Alıntı:
cimcoz tarafından gönderildi Mesajı Görüntüle
Elinize sağlık. Çok teşekkür ederim, tam istediğim de buydu.
Rica ederim.İsteğinizin olmasına memnun oldum.Dönüş taptığınız için bende teşekkür ederim.Kolay gelsin.
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-10-2017, 22:33   #5
Haluk
Özel Üye
 
Haluk kullanıcısının avatarı
 
Giriş: 07/07/2004
Şehir: Turkiye
Mesaj: 4,936
Excel Vers. ve Dili:
Office 2010 - Ingilizce
Varsayılan

Ufak bir not:

Yukarıda "topla.çarpım" formüllerindeki dizilerin her ikisi de sonuç olarak "True" veya "False" sonucunu döndürdüğü için, dizilerin çarpımından çıkan sonucu tekrar "--" ile çarparak XL'e tekrar işlem yaptırmaya gerek yok.

Demek istediğim;

--(True X False)

ile;

(True X False)

her ikisi de "0" (sıfır) yani, "False" sonucunu geri döndürür.

.
__________________
Kod anlatılmaz,yazılır !
Burası Excel vadisi ....
Haluk Çevrimiçi   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 17:53


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden