Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Beyin Fırtınası
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Beyin Fırtınası Bu başlıkta, ilginç olduğunu düşündüğünüz sorularınızı, bir problem şeklinde sorabilir, alternatif olduğunu düşündüğünüz çözümlerinizi paylaşabilirsiniz. (Bu başlıkta yeni konu açılması onaya bağlıdır.)
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 28-04-2007, 08:41   #21
karga
 
Giriş: 23/04/2007
Mesaj: 2
Excel Vers. ve Dili:
2007
Varsayılan

arkadaşlar bende şöyle bir makro hazırladım kontrol edersiniz sorusu olan olursa yanıtlarım


For i = 1 To 100
s = Sheets(1).Cells(i, 7).Value
If s = "" Then
i = 1000
Else
For j = 1 To 10000
If Sheets(1).Cells(j, 1).Value < Sheets(1).Cells(j, 2).Value Then
d1 = Sheets(1).Cells(j, 1).Value
d2 = Sheets(1).Cells(j, 2).Value
Else
d2 = Sheets(1).Cells(j, 1).Value
d1 = Sheets(1).Cells(j, 2).Value
End If
d3 = Sheets(1).Cells(j, 3).Value
If d1 <= s And s <= d2 Then
Sheets(1).Cells(i, 8).Formula = d3
j = 10000
Else
End If
Next
End If
Next
karga Çevrimdışı   Alıntı Yaparak Cevapla
Eski 24-11-2007, 23:32   #22
Excel113
 
Giriş: 15/11/2007
Şehir: Erzincan
Mesaj: 125
Excel Vers. ve Dili:
Excel 2003 Türkçe
Varsayılan

Konuyu yanlış anlamadıysam...
H sütununa yazılacak, en kısa formüller aşağıdaki gibi olmalı,

=EĞER(VE(G2>=A2;G2<=B2);C2;"")
=EĞER(VE(G3>=A3;G3<=B3);C3;"")
=EĞER(VE(G4>=A4;G4<=B4);C4;"")
=EĞER(VE(G5>=A5;G5<=B5);C5;"")
=EĞER(VE(G6>=A6;G6<=B6);C6;"")
Excel113 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 29-05-2008, 11:54   #23
XelNaga DoUrden
 
Giriş: 06/04/2008
Şehir: İstanbul
Mesaj: 1
Excel Vers. ve Dili:
Microsoft Excel 2003
Varsayılan

Merhaba arkadaşlar bende bu konu ile ilgili bir makro hazırladım ve bunu bir butona atadım...


Sub arama()
'İlk olarak G sütunundaki markalar siliniyor çünkü hiç bir değer aralığına girmeyecek sayılar için Marka kısmının boşluk olmasını istedim.

a = 1
Do
a = a + 1
Cells(a, 8).Value = ""
Loop Until Cells(a + 1, 8).Value = ""

'Daha sonra ise deger aralıklarına göre marka yazılıyor.
a = 1
Do
a = a + 1
b = 1
Do
b = b + 1
If Cells(a, 7) >= Cells(b, 1) And Cells(a, 7) <= Cells(b, 2) Then
Cells(a, 8).Value = Cells(b, 3).Value
End If
Loop Until Cells(b+1, 2).Value = ""
Loop Until Cells(a+1, 7).Value = ""


End Sub
XelNaga DoUrden Çevrimdışı   Alıntı Yaparak Cevapla
Eski 30-03-2010, 11:20   #24
fatihbuyun
 
Giriş: 30/03/2010
Şehir: Antalya
Mesaj: 1
Excel Vers. ve Dili:
Microsoft Office Exce 2007 / Türkçe
Varsayılan

Merhaba

Açıklamamı ekli, dosyada yazdım.
istenen : İki değer arasında kalan verinin karşılığı olan değerin istediğimiz sütuna getirilmesi.
Bir bakıma düşeyara diyebiliriz ama nasıl..

Daha önce Türker arkadaşım tarafından sütun ilavesi yapılarak formülle çözülmüştü.
Bende aynı konuyu soran başka bir arkadaşıma aynı çözümü önermiştim

Alternatifleri olabilirmi...

Burada ilk çözüm excel'in kendi işlevlerini kullanmak.Tabiiki diğer arkadaşlara yol göstermek açısındam Kullanıcı tanımlı fonk.ve makro ilede çözümler üretebiliriz.
************************************************** ******************
Merhaba ,
Zafer arkadaşım bana excel dosyasını benim mail adresime fatihbuyun@gmail.com'a gönderebilirmsin acaba ,
ekli dosyayı göremiyorum.
Teşekkür ederim.
fatihbuyun Çevrimdışı   Alıntı Yaparak Cevapla
Eski 01-04-2010, 16:49   #25
zafer
Super Moderator
 
zafer kullanıcısının avatarı
 
Giriş: 08/03/2005
Mesaj: 3,501
Excel Vers. ve Dili:
OFFICE 2003 TÜRKÇE OFFICE 2010 TÜRKÇE
Varsayılan

Merhaba


istediğiniz dosyayı yeniledim.
__________________


LÜTFEN TÜRKÇEMİZE SAHİP ÇIKALIM.

MEVZU-U BAHİS VATANSA GERİSİ TEFERRUATTIR

Biz burada hep beraber, sevginin,saygının, alınterinin, mutluluğun makrosunu yazıyoruz
zafer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-01-2012, 14:00   #26
delikadir8001
 
Giriş: 19/01/2012
Şehir: OSMANİYE
Mesaj: 1
Excel Vers. ve Dili:
excel 2003 türkçe
Varsayılan

=EĞER(A1=1;"BİR";EĞER(A1=2;"İKİ";EĞER(A1=3;"ÜÇ")))
bu işlemi eğer kullanarak 15 kadar çıkarmam gerekiyor 8 den sonra takılıp kaldım lütfen bana yardımcı olun iç içe eğer 8 den sonra nasıl kullanılıyor

Bu mesaj en son " 19-01-2012 " tarihinde saat 14:26 itibariyle delikadir8001 tarafından düzenlenmiştir....
delikadir8001 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 23-03-2014, 00:28   #27
kenevir47
 
Giriş: 14/01/2006
Şehir: Mardin
Mesaj: 40
Excel Vers. ve Dili:
2010 Türkçe
Varsayılan

Bu forumda bilgi alış verişinde paraya mı bağlanmış ne iş anlamadım yaklaşık olarak şu ana kadar 200 ün üzerinde değişik bilgi paylaşım forumlara üye olmuşum il kez ben böylesine rastlıyorum. Biri bir formül vermiş doya ekinde dosya ya bakmak için Gold üyeliğiniz olması gerekiyor diyor.
kenevir47 Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 22:55


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden