Yalnız Mesajı Göster
Eski 10-04-2007, 02:08  
Suskun
Altın Üye
 
Giriş: 27/11/2006
Mesaj: 74
Excel Vers. ve Dili:
Excel 16
Varsayılan

Merhaba,

Problemde Çifte sorgulama yapıldığı için (Departman ve Gün) Düşeyara fonksiyonu yerine daha esnek ve işlevsel İNDİS ve KAÇINCI Fonksiyonlarını kullanmak daha doğru geldi bana.

B6 Hücresideki formul şöyle:

=İNDİS('GÜNLÜK GELİRLER'!$A$1:$AF$26;KAÇINCI('ÖZET RAPOR'!A6;'GÜNLÜK GELİRLER'!$A$1:$A$26;); KAÇINCI('ÖZET RAPOR'!$B$1;'GÜNLÜK GELİRLER'!$A$1:$AF$1;))

İNDİS Alanımız Günlük Gelirler sayfasının A1:AF26 alanı;
1.Sorgumuzda A6 Değerinin (Departman Adının) Günlük Gerlirler sayfasının A1:A26 alanında KAÇINCI Olduğunu Sorguluyoruz,
2. Sorgumuzda B1 değerinin (Günün) Günlük Gelirler sayfasının A1:AF1 Alanında KAÇINCI olduğunu Sorguluyoruz

Örnekte Departman adları sabit, güne göre toplam departman gelirerini bulabiliyoruz.
Örneğe uygun olarak Gün ve Departman Seçip Gelirini Nasıl bulurduk diye düşünenler için ikinci bir sayfada Gün ve Departman Adını seçerek Departmanın Günlük gelirini bulan bir çalışma sayfası ekledim.

BU sayfada Gün ve Departman seçimi için Günler ve Departmanlar Alan adlarını tanımlayarak 2 adet veri doğrulama ekledim.

Kolay gelsin
Eklenmiş Dosyalar
Dosya Türü: xls GununSorusuCozum.xls (39.0 KB, 284 Görüntülenme)
Suskun Çevrimdışı   Alıntı Yaparak Cevapla