Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 03-05-2010, 23:51   #1
sin77
 
Giriş: 27/01/2006
Şehir: ordu
Mesaj: 105
Varsayılan Verileri ayrı sutunda sıralamak

Arkadaşlar ekte gönderdiğim örnek verileri ayrı sutunda , aradaki boş hücreler hariç ve karşılık gelen sutun değeri ile birlikte sıralamak için nasıl formüller kullanabilirim. yardımcı olurmusunuz. örnekte daha kapsamlı açıkladım.
Eklenmiş Dosyalar
Dosya Türü: xls Örnek.xls (14.0 KB, 15 Görüntülenme)
sin77 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-05-2010, 00:08   #2
Ergün Güler
 
Ergün Güler kullanıcısının avatarı
 
Giriş: 05/01/2009
Şehir: İstanbul
Mesaj: 1,589
Excel Vers. ve Dili:
2003 Türkçe
Varsayılan

Selam Sayın Sin77,
ekteki örnek dosyanızın
H1 hücresine:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(EHATALIYSA(İNDİS($A$1:$B$30;KÜÇÜK(EĞER($B$1:$B$30<>"";SATIR($B$1:$B$30));SATIR());1));"";İNDİS($A$1:$B$30;KÜÇÜK(EĞER($B$1:$B$30<>"";SATIR($B$1:$B$30));SATIR());1))
I1 hücresine:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(EHATALIYSA(İNDİS($A$1:$B$30;KÜÇÜK(EĞER($B$1:$B$30<>"";SATIR($B$1:$B$30));SATIR());2));"";İNDİS($A$1:$B$30;KÜÇÜK(EĞER($B$1:$B$30<>"";SATIR($B$1:$B$30));SATIR());2))
girniz ve aşağıya doğru çoğaltınız.
Ancak, formüller dizi formülüdür. Bu yüzden hücre içine formül yazdıktan sonra ENTER'a basmadan CTRL+SHIFT+ENTER tuşlarını birlikte uygulayınız.
yoksa formül doğru çalışmayacaktır.
Ben 30 satıra kadar düzenledim siz arzu ettiğiniz kadar ayarlayabilirsiniz

Bu mesaj en son " 04-05-2010 " tarihinde saat 01:29 itibariyle Ergün Güler tarafından düzenlenmiştir....
Ergün Güler Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-05-2010, 00:42   #3
sin77
 
Giriş: 27/01/2006
Şehir: ordu
Mesaj: 105
Varsayılan

üstad teşekkürler. yanlız 4. veri değeri olmadığından formül hata veriyor. hata yerine boş gösterme durumu olabilirmi?
sin77 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-05-2010, 01:31   #4
Ergün Güler
 
Ergün Güler kullanıcısının avatarı
 
Giriş: 05/01/2009
Şehir: İstanbul
Mesaj: 1,589
Excel Vers. ve Dili:
2003 Türkçe
Varsayılan

Alıntı:
sin77 tarafından gönderildi Mesajı Görüntüle
üstad teşekkürler. yanlız 4. veri değeri olmadığından formül hata veriyor. hata yerine boş gösterme durumu olabilirmi?
2.sıradaki kodları yeniden düzenledim. hatalı sonuçları boş gösterecektir. CTRL+SHIFT+ENTER birlikte uygulamayı unutmayınız.
Ergün Güler Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 23:26


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Rampa- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Şişli Avukat- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Çorlu Havuz- Çorlu Havuz- Çorlu Perde Yıkama- Okul Danışmanlık- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım- Çorlu Sondaj- Çorlu Etüt- Futbol Cafe- Beylikdüzü Temizlik- Çorlu Kurs- Çorlu Ders- İzmit Mimar- Hurda Bakır Kablo- Hurda Bakır Kablo- Çorlu Pronet- Çorlu Yönetim- Çorlu Apartman Yönetimi- Çorlu Marangoz- Çorlu Avukat- Çorlu Su Arıtma- Çorlu Kompresör- İstanbul İnşaat-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden