Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 09-08-2017, 15:31   #1
bulento5
 
Giriş: 10/10/2010
Şehir: bolu
Mesaj: 4
Excel Vers. ve Dili:
office 2007
Smile Saat dilimleri arası biçimlendirme

Arkadaşlar merhaba,
excell'de aşağıda belirtilen saatler arasında yer alan vardiya türüne göre formüle etmek istiyorum. Bir kaç deneme yaptım fakat sanırım beceremedim.
kısacası saat verisinin olduğu yerden aldığı saat bilgisine göre diğer bir satırda A yada B yada C yazmasını istiyorum.
teşekkürler.

24:00:00 8:00:00 A
8:00:00 16:00:00 B
16:00:00 24:00:00 C

16:01:21
18:43:07
23:05:36
20:42:02
22:29:57
01:09:38
07:29:05
12:50:32
05:39:58
23:33:58
07:07:50
15:37:42
09:08:51
15:48:58
bulento5 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-08-2017, 16:09   #2
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 8,642
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba.

Basit düşünmekte yarar var. Saat verisi A1 hücresinde ise;
(Elbette birçok alternatif formül oluşturulabilir)
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(A1>=16/24;"C";EĞER(A1>=8/24;"B";EĞER(A1>=1/24;"A";"")))
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-08-2017, 16:16   #3
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Şehir: Ankara
Mesaj: 14,202
Excel Vers. ve Dili:
Excel, 2016 - İngilizce
Varsayılan

.

Saatler A1 hücresinden aşağıya doğru ise;

B1 hücresine:

İngilizcesi;

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=LOOKUP(A1;{0;0,3333;0,6667};{"A";"B";"C"})
Türkçesi:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=ARA(A1;{0;0,3333;0,6667};{"A";"B";"C"})
yazıp, aşağıya doğru kopyalayın.



.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-08-2017, 16:21   #4
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereðli
Mesaj: 505
Varsayılan

Alternatif,
Saat aralığı aynı hücrede ise
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(VE(YUVARLA(PARÇAAL(A1;1;BUL(" ";A1))+0;2)>=1;YUVARLA(KIRP(PARÇAAL(A1;BUL(" ";A1);UZUNLUK(A1)))+0;2)<=0,33);"A";EĞER(VE(YUVARLA(PARÇAAL(A1;1;BUL(" ";A1))+0;2)>=0,33;YUVARLA(KIRP(PARÇAAL(A1;BUL(" ";A1);UZUNLUK(A1)))+0;2)<=0,67);"B";EĞER(VE(YUVARLA(PARÇAAL(A1;1;BUL(" ";A1))+0;2)>=0,67;YUVARLA(KIRP(PARÇAAL(A1;BUL(" ";A1);UZUNLUK(A1)))+0;2)<=1);"C")))
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-08-2017, 16:30   #5
bulento5
 
Giriş: 10/10/2010
Şehir: bolu
Mesaj: 4
Excel Vers. ve Dili:
office 2007
Varsayılan

Çok teşekkür ederim.
bulento5 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-08-2017, 16:39   #6
bulento5
 
Giriş: 10/10/2010
Şehir: bolu
Mesaj: 4
Excel Vers. ve Dili:
office 2007
Varsayılan

Arkadaşlar hızlı yanıtlarınız için ayrıca teşekkür ederim, belirtmiş olduğunuz gibi saat formülü çalıştı fakat farklı bir veri tabanından gelen bilgi de şu şekilde aynı formülü buna nasıl uygularım.

Aynı satır içerisinde ilk önce tarih sonra saat bilgisi gelmekte formülü sadece saat bilgisine göre entegre edebilir miyiz ?
şimdiden çok tşk.

18.4.17 15:48
19.4.17 6:54
17.7.17 18:28
4.4.17 15:48
22.3.17 2:00
bulento5 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-08-2017, 16:48   #7
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 8,642
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Hangi formülü kullanıyorsanız o formülde A1 yerine MOD(A1;1) yazarak deneyin.
Sorun yaşarsanız gerçek verilerden oluşan bir örnek belge yükleyin.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 11-08-2017, 14:17   #8
bulento5
 
Giriş: 10/10/2010
Şehir: bolu
Mesaj: 4
Excel Vers. ve Dili:
office 2007
Smile

merhaba,
İlginizden dolayı çok teşekkür ederim.
bulento5 Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 17:09


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Hurda - Torna - Çorlu Web Tasarım - Tarot Falı - Fenerbahçe Haberleri - Trakya Haberleri - investing - Hurda - Kozmetik Ürünler - Excel Eğitimi - Lingerie - Dyeing Machine - Çorlu Temizlik- Hazır Site- SEO- Çorlu Burun Estetiği- Karton Bardak- Çorlu Pimapenci- İstanbul Avukat- Çorlu Kekemelik- Edirne Su Arıtma- Çorlu Perde Yıkama- Marmara Ereğlisi Hotel- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Kamera- Çorlu Fiber- Çorlu Araç Takip-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden