Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 09-01-2018, 21:06   #1
giwara
Altın Üye
 
Giriş: 28/12/2017
Mesaj: 21
Excel Vers. ve Dili:
Office 365, ZohoDocs, GoogleSheet
Varsayılan Hücre Değerine Göre 2 Diğer Hücreye Otomatik Veri Yazdırma

Merhabalar,

Elimizde A B C sütunları var.

A sütununa değeri girdiğimizde o değere karşılık gelen değerleri (biz belirleyeceğiz) B ve C sütunlarına otomatik olarak yazdırmak istiyoruz.

Mesela A sütununa yazdığımız DENEME değeri için, B hücresine TR yazdıracağız, C hücresine QM yazdıracağız.
DENEME 2 değeri için, B hücresine YT yazdıracağız, C hücresine MT yazdıracağız.
Bazen hem DENEME3, hem de DENEME4 değeri için aynı değerlerde yazılabilir.

Toplamda 200 tane A sütununa yazılabilecek değerimiz var. Yapılabilir mi?
giwara Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-01-2018, 21:27   #2
ASLAN7410
Altın Üye
 
ASLAN7410 kullanıcısının avatarı
 
Giriş: 15/07/2012
Şehir: Aslan ERASLAN - ANKARA
Mesaj: 1,737
Excel Vers. ve Dili:
Ofis 2013 Türkçe
Varsayılan

Merhaba.

Veri A1 hücresinde olduğu varsayılırsa.

B1 hücresine
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(A1="DENEME";"TR";EĞER(A1="DENEME2";"YT";EĞER(YADA(A1="DENEME3";A1="DENEME4");"AA";"")))
C1 hücresine
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(A1="DENEME";"QM";EĞER(A1="DENEME2";"TM";EĞER(YADA(A1="DENEME3";A1="DENEME4");"BB";"")))

Formüllerdeki renkli olan AA ve BB yerine istediğiniz değeri yazabilirsiniz.

Her iki formülü seçerek istediğiniz satıra kadar uzatabilirsiniz.
__________________
.
Her zaman yardımcı olmak güzel bir şeydir...

Bu mesaj en son " 09-01-2018 " tarihinde saat 21:45 itibariyle ASLAN7410 tarafından düzenlenmiştir....
ASLAN7410 Çevrimiçi   Alıntı Yaparak Cevapla
Eski 10-01-2018, 09:17   #3
giwara
Altın Üye
 
Giriş: 28/12/2017
Mesaj: 21
Excel Vers. ve Dili:
Office 365, ZohoDocs, GoogleSheet
Varsayılan

200 tane değeri böyle yazdığımızda herhangi bir yavaşlık yaşar mıyız?

Kod ile yapılabilirse çok daha rahat olur gibi geliyor.
giwara Çevrimdışı   Alıntı Yaparak Cevapla
Eski 11-01-2018, 16:58   #4
ASLAN7410
Altın Üye
 
ASLAN7410 kullanıcısının avatarı
 
Giriş: 15/07/2012
Şehir: Aslan ERASLAN - ANKARA
Mesaj: 1,737
Excel Vers. ve Dili:
Ofis 2013 Türkçe
Varsayılan

Merhaba.

Aşağıdaki kodu bir butona bağlayın.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
Sub İkiFormül()

With Range("B1:B200")
    .Formula = "=IF(RC[-1]=""DENEME"",""TR"",IF(RC[-1]=""DENEME2"",""YT"",IF(OR(RC[-1]=""DENEME3"",RC[-1]=""DENEME4""),""AA"","""")))"
    .Value = .Value
End With

With Range("C1:C200")
    .Formula = "=IF(RC[-2]=""DENEME"",""QM"",IF(RC[-2]=""DENEME2"",""TM"",IF(OR(RC[-2]=""DENEME3"",RC[-2]=""DENEME4""),""BB"","""")))"
    .Value = .Value
End With


End Sub
__________________
.
Her zaman yardımcı olmak güzel bir şeydir...
ASLAN7410 Çevrimiçi   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 20:07


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Rampa- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Şişli Avukat- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Çorlu Havuz- Çorlu Havuz- Çorlu Perde Yıkama- Okul Danışmanlık- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım- Çorlu Sondaj- Çorlu Etüt- Futbol Cafe- Beylikdüzü Temizlik- Çorlu Kurs- Çorlu Ders- İzmit Mimar- Hurda Bakır Kablo- Hurda Bakır Kablo- Çorlu Pronet- Çorlu Yönetim- Çorlu Apartman Yönetimi- Çorlu Marangoz- Çorlu Avukat-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden