Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 25-12-2017, 23:13   #1
cancan1221
 
Giriş: 26/01/2017
Şehir: balıkesir
Mesaj: 31
Excel Vers. ve Dili:
excel2007
Varsayılan formül içerisinde değişken kitap adı kullanma

Merhaba,
sayfada bakmadığım yer kalmadı gibi,
=DÜŞEYARA(N5;'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\[örnek.xlsm]İSLEMHAREKET'!$A$3:$Q$15;12;YANLIŞ)

yukarıdaki formda örnek.xlsm yi a1 deki seçilen değerden almam gerekiyor, nasıl yapabilirim. yardımlarınız.
cancan1221 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-12-2017, 23:23   #2
Ahmet ÖZGÜR
Altın Üye
 
Ahmet ÖZGÜR kullanıcısının avatarı
 
Giriş: 08/06/2010
Şehir: İstanbul
Mesaj: 278
Excel Vers. ve Dili:
Office 2003 TR Office 2007
Varsayılan

Örnek dosya yüklermisiniz benzer birşey olursa daha çabuk çözüme ulaşabilirsiniz. INDIS formülüde kullanılabilir gibi!!
__________________
"Korkaklıkta ar, İlerlemekte şeref var." (Ebu Dücane R.A.)
Ahmet ÖZGÜR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 25-12-2017, 23:44   #3
cancan1221
 
Giriş: 26/01/2017
Şehir: balıkesir
Mesaj: 31
Excel Vers. ve Dili:
excel2007
Varsayılan

Alıntı:
Ahmet ÖZGÜR tarafından gönderildi Mesajı Görüntüle
Örnek dosya yüklermisiniz benzer birşey olursa daha çabuk çözüme ulaşabilirsiniz. INDIS formülüde kullanılabilir gibi!!
hocam örneğe gerek varmı. çok büyük dosya,

=DÜŞEYARA(N5;'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\[örnek.xlsm]İSLEMHAREKET'!$A$3:$Q$15;12;YANLIŞ)

örnek.xlsm yazan yeri a1 hücresi veya herhangi bir hücrede yazan mesela ahmet
olacak.
=DÜŞEYARA(N5;'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\[ahmet.xlsm]İSLEMHAREKET'!$A$3:$Q$15;12;YANLIŞ)
a1 hücresinde ahmet yazıyor, yukarıda verilen örnekte ahmet.xlsm den düşey arama yapacak.

mehmet ise mehmet.xlsm den arama yapacak gibi.

Bu mesaj en son " 26-12-2017 " tarihinde saat 00:15 itibariyle cancan1221 tarafından düzenlenmiştir....
cancan1221 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-12-2017, 09:24   #4
cancan1221
 
Giriş: 26/01/2017
Şehir: balıkesir
Mesaj: 31
Excel Vers. ve Dili:
excel2007
Varsayılan güncel

Merhaba,
yardımcı olacak yokmudur?
cancan1221 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-12-2017, 12:54   #5
Ahmet ÖZGÜR
Altın Üye
 
Ahmet ÖZGÜR kullanıcısının avatarı
 
Giriş: 08/06/2010
Şehir: İstanbul
Mesaj: 278
Excel Vers. ve Dili:
Office 2003 TR Office 2007
Varsayılan

Bu formülü sizmi kurdunuz bilemiyorum.Fakat anladığım kadarı ile,

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(N5;'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\[örnek.xlsm]İSLEMHAREKET'!$A$3:$Q$15;12;YANLIŞ)
Kırmızı ile işaretli olan "N5" Aranan Değerdir. Aranan değere göre sizin seçim yaptığınız hücrelerde arama yapacaktır, Formülde "N5" i "A1" ile değiştiririseniz yeterli olacak diye düşünüyorum, sütun sayısı ve aralığı çıkan sonuca göre değiştirebilirsiniz.
__________________
"Korkaklıkta ar, İlerlemekte şeref var." (Ebu Dücane R.A.)
Ahmet ÖZGÜR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-12-2017, 13:37   #6
cancan1221
 
Giriş: 26/01/2017
Şehir: balıkesir
Mesaj: 31
Excel Vers. ve Dili:
excel2007
Varsayılan

Alıntı:
Ahmet ÖZGÜR tarafından gönderildi Mesajı Görüntüle
Bu formülü sizmi kurdunuz bilemiyorum.Fakat anladığım kadarı ile,

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(N5;'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\[örnek.xlsm]İSLEMHAREKET'!$A$3:$Q$15;12;YANLIŞ)
Kırmızı ile işaretli olan "N5" Aranan Değerdir. Aranan değere göre sizin seçim yaptığınız hücrelerde arama yapacaktır, Formülde "N5" i "A1" ile değiştiririseniz yeterli olacak diye düşünüyorum, sütun sayısı ve aralığı çıkan sonuca göre değiştirebilirsiniz.
hocam demek istediğim,

=DÜŞEYARA(N5;'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\[örnek.xlsm]İSLEMHAREKET'!$A$3:$Q$15;12;YANLIŞ)

formül yularıdaki

benim yapmak istediğim

=DÜŞEYARA(N5;'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\[a1.xlsm]İSLEMHAREKET'!$A$3:$Q$15;12;YANLIŞ)

yeni a1 hücresindeki değer ne ise o kitaptan düşey arama yapacak
cancan1221 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 27-12-2017, 09:11   #7
cancan1221
 
Giriş: 26/01/2017
Şehir: balıkesir
Mesaj: 31
Excel Vers. ve Dili:
excel2007
Varsayılan

güncelll...
cancan1221 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 27-12-2017, 09:38   #8
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Şehir: Ankara
Mesaj: 14,564
Excel Vers. ve Dili:
Excel, 2016 - İngilizce
Varsayılan

.

Veri aldığınız dosya açık olmalı.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=VLOOKUP(N5;INDIRECT("'C:\STOK PROGRAMI 2018\MALZEME_KAYIT_1205\
 ["& A1.xlsm & "]İSLEMHAREKET'!$A$3:$Q$15");12;0)

VLOOKUP=DÜŞEYARA
INDIRECT=DOLAYLI

.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 27-12-2017, 10:08   #9
cancan1221
 
Giriş: 26/01/2017
Şehir: balıkesir
Mesaj: 31
Excel Vers. ve Dili:
excel2007
Varsayılan

hocam çok sağolun cevabınız için. kapalı olarak kullanma imkanı yokmudur.
cancan1221 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 27-12-2017, 15:50   #10
cancan1221
 
Giriş: 26/01/2017
Şehir: balıkesir
Mesaj: 31
Excel Vers. ve Dili:
excel2007
Varsayılan

Böyle bir sorun ile karşılaşanlara duyrulur.
Bu konu hakkında boşuna uğraşmayın makro ile oluyor. çok uğraştım ancak maalesef makrosuz beceremedim
cancan1221 Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 22:09


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden