Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 07-01-2018, 09:12   #1
cileri33
 
Giriş: 07/01/2018
Şehir: Mugla
Mesaj: 5
Excel Vers. ve Dili:
Excel 2010 TR
Varsayılan Düşeyara Formülünün Kes/Yapıştır ile bozulması

Merhabalar,

Sayfa1 dosyamda R sütünuna =DÜŞEYARA(H8;DATA2;2;0) formülünü yazıyorum. DATA2 olarak gördüğü yer Sayfa2 de mevcut.

Formül normal şartlarda düzgün çalışıp istediğim sonuçları veriyor.
Ancak eğer ki ben H9 satırında yazılı veriyi kes komutu kullanıp H9 sütununa yapıştırırsam, R sütünundaki düzgün formülü bozarak =DÜŞEYARA(#BAŞV!;DATA2;2;0) olarak değiştirerek herhangi bir sonuç vermiyor.

Bende mecburen her satırı copy/paste yapıp daha sonra kopyaladığım satırları silerek vakit kaybediyorum.

Örnek dosya aşağıdaki linte mevcut. Hataları ilgili satırlara açıklama olarak ta yazdım.

http://www.dosya.tc/server11/sjo5zu/Duseyara.xlsx.html


Bahsettiğim kes/yapıştır komutu işimi çok kolaylaştırdığı için bu formülü bozmasını engelleyecek bir çözüm yolu var mıdır?

Bu mesaj en son " 07-01-2018 " tarihinde saat 09:33 itibariyle cileri33 tarafından düzenlenmiştir....
cileri33 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 10:42   #2
cems
Altın Üye
 
cems kullanıcısının avatarı
 
Giriş: 02/09/2005
Şehir: İstanbul
Mesaj: 1,882
Excel Vers. ve Dili:
office 2003 tr + office 2010 tr 32bit
Varsayılan

Alıntı:
cileri33 tarafından gönderildi Mesajı Görüntüle

Bahsettiğim kes/yapıştır komutu işimi çok kolaylaştırdığı için bu formülü bozmasını engelleyecek bir çözüm yolu var mıdır?
Tablo boş olduğu için amaç anlaşılır değil. Ancak , B lerdeki değişim ve düşeyara formülünde indis sayısı olan 2 artırıldığında sanırım istediğiniz oluyor. B ler değişmediği sürece düşeyara indis değiştiğinden dolayı isabet eden hücrede bir veri bulamaz.

http://s7.dosya.tc/server/cglla3/Duseyara.rar.html
cems Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 11:02   #3
cileri33
 
Giriş: 07/01/2018
Şehir: Mugla
Mesaj: 5
Excel Vers. ve Dili:
Excel 2010 TR
Varsayılan

Aslında tablo boş değil formül satırları beyaz punto ile gizli.
Rengini siyah yapınca gözüküyor.

Şimdi tablonun orjinal halini paylaşıyorum.

http://www.dosya.tc/server11/9c1eng/Duseyara2.xlsx.html

Amaç G ve H sütunlarında ne görürse, Sayfa 2 ye gidip G ve H sütununda gördüğü verinin karşılığını alarak Q ve R sütunlarına yazması.

Yani TK2552 = THY3HJ , TK2553 = THY1TP

Bunları değer yapıştır olarak koyarsam yani copy + 123 paste = 8,9,10,11 satırlarındaki gibi doğru hesaplama yapıyor.

Ancak 23-24-25-26H sütünlarından bir veriyi kesip 15-16-17-18h sütunlarına yapıştırırsam 15-16-17-18 ve 23-24-25-26H sütünlarındaki formülleri bozuyor.

Ben istiyorum ki değer yapıştır gibi, keserek yapıştırsın ve formüllerimi bozmasın.
cileri33 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 11:34   #4
cems
Altın Üye
 
cems kullanıcısının avatarı
 
Giriş: 02/09/2005
Şehir: İstanbul
Mesaj: 1,882
Excel Vers. ve Dili:
office 2003 tr + office 2010 tr 32bit
Varsayılan

Q8 ve R8 hücrelerinde formülü oluşturduktan sonra kenarından tutup aşağı çektiğinizde formül kendini artarak zaten yazıyor...

Callsign sayfasına bağlı olarak Daily sayfasının G ve H sütunlarının neresinde TK ile yeni bir veri yapıştırırsanız yapıştırın , THY lar normal olarak Q ve R ye zaten geliyor. Yani sayfanın kurulumu bitmiş oluyor . Bundan sonra değişken sadece G ve H da olabilir, yani TK ların değişmesi yeterli ve gerekli .

Siz neden tekrar Q ve R sayfalarına kes yapıştır yapıyorsunuz ?
cems Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 11:46   #5
cileri33
 
Giriş: 07/01/2018
Şehir: Mugla
Mesaj: 5
Excel Vers. ve Dili:
Excel 2010 TR
Varsayılan

Öncelikle formülleri aşağı sürüklemem en basit çözüm ancak excel dosyayı sadece ben kullanmıyorum. Ortak kullanımda olan bir dosya olduğu için diğer kullanıcılar formülleri silip/bozamasın diye ben Q ve R sütunlarını korumalı yapıyorum. Bu durumda kes yapıştır işleminde formül silinirse şifreyi bilmeyen kullanıcı formülü de değiştiremiyor içeriği de.

Kes yapıştıra ihtiyaç sebebim;
Benim ilk kopyala yaptığım program her şeyi tek satırda göstermiyor 1. ve 2. tarihi ve TK2552 TK2553 satırlarını birer alta koyuyor.
Yan TK2552 G3 - TK2553 H4 sütununda geldiği ve benim onları yan yana koymam gerektiği için en kolay yöntem ya 1 satırı komple silip yukarı sürükle demek yada H4 ü H3 e kes yapıştır yapmak. Ancak 2 yöntemde formülleri bozuyor.

Eğer ki bu sorunu çözemez isem şifre koymaktan vazgeçip tüm kullanıcılara ilk formülü aşağı sürükleyin şeklinde bilgi vermem gerekecek...
cileri33 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 12:03   #6
cems
Altın Üye
 
cems kullanıcısının avatarı
 
Giriş: 02/09/2005
Şehir: İstanbul
Mesaj: 1,882
Excel Vers. ve Dili:
office 2003 tr + office 2010 tr 32bit
Varsayılan

Alıntı:
cileri33 tarafından gönderildi Mesajı Görüntüle
Kes yapıştıra ihtiyaç sebebim;
Benim ilk kopyala yaptığım program her şeyi tek satırda göstermiyor 1. ve 2. tarihi ve TK2552 TK2553 satırlarını birer alta koyuyor.
Yan TK2552 G3 - TK2553 H4 sütununda geldiği ve benim onları yan yana koymam gerektiği için en kolay yöntem ya 1 satırı komple silip yukarı sürükle demek yada H4 ü H3 e kes yapıştır yapmak. Ancak 2 yöntemde formülleri bozuyor.
.
Anladığım doğru farzederek konuyu tersten düşünürsek :
THY sütunlarında ilk anda işimiz yok , bütün mesele gelen TK verisinde verinin doğru yerinde olmaması .. Bu durumda diğer dosya ortada olmadığına göre ve hep aynı bozuklukla geldiği varsayılarak aklen tarifle :

1-Makro kaydet i açarak TK sütunundaki düzeltmeye dair makro kaydetmek
2-Bunu bir tuşun altına yerleştirmek.
3-Q ve R sütunlarını da makro kaydeti açarak aşağı çekmek
4-Bu kaydı ilk kayıtla birleştirmek ,yani düzeltme artı formül çekmeyi makro ile yapmak
5-sütun kilitlemeyi de kaydederek en sona eklemek ve tuş altında tam bir hareket kodu oluşturmak ve tek tuşla düzeltme uzatma kilitleme yapmak ,dahası bu TK verilerinin sürekli akışta olduğunu da farzedersek belli zaman aralığında kendiliğinden çalışması veriyi doğru şekilde otomatik yerleştirmesi de sağlanabilir. Bu durumda dosyaya dokunmaya da gerek kalmaz ,açık olması update olmasına yeter bu şekilde ;

Sorun ilanihayet çözülebilir. Hatta bozuk verinin alınması da belki kod ile yapılabilir, yapılamazsa da TK kısımlarının yapıştırılması da yeterli olabilir.

Ya da sayfadaki kilidi açıp kapatmayı ve q ile r yi aşağı çekmeyi kullananlara öğretin ve bozulma olduğunda düzeltmelerini sağlayın.

Bunun dışında istediğiniz şekilde q ve r üzerinden kes yapıştıra çözüm ; varsa da benim bilgimi aşıyor olabilir.

Bu mesaj en son " 07-01-2018 " tarihinde saat 12:14 itibariyle cems tarafından düzenlenmiştir....
cems Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 13:07   #7
cileri33
 
Giriş: 07/01/2018
Şehir: Mugla
Mesaj: 5
Excel Vers. ve Dili:
Excel 2010 TR
Varsayılan

Alıntı:
cems tarafından gönderildi Mesajı Görüntüle
Anladığım doğru farzederek konuyu tersten düşünürsek :
THY sütunlarında ilk anda işimiz yok , bütün mesele gelen TK verisinde verinin doğru yerinde olmaması .. Bu durumda diğer dosya ortada olmadığına göre ve hep aynı bozuklukla geldiği varsayılarak aklen tarifle :

1-Makro kaydet i açarak TK sütunundaki düzeltmeye dair makro kaydetmek
2-Bunu bir tuşun altına yerleştirmek.
3-Q ve R sütunlarını da makro kaydeti açarak aşağı çekmek
4-Bu kaydı ilk kayıtla birleştirmek ,yani düzeltme artı formül çekmeyi makro ile yapmak
5-sütun kilitlemeyi de kaydederek en sona eklemek ve tuş altında tam bir hareket kodu oluşturmak ve tek tuşla düzeltme uzatma kilitleme yapmak ,dahası bu TK verilerinin sürekli akışta olduğunu da farzedersek belli zaman aralığında kendiliğinden çalışması veriyi doğru şekilde otomatik yerleştirmesi de sağlanabilir. Bu durumda dosyaya dokunmaya da gerek kalmaz ,açık olması update olmasına yeter bu şekilde ;

Sorun ilanihayet çözülebilir. Hatta bozuk verinin alınması da belki kod ile yapılabilir, yapılamazsa da TK kısımlarının yapıştırılması da yeterli olabilir.

Ya da sayfadaki kilidi açıp kapatmayı ve q ile r yi aşağı çekmeyi kullananlara öğretin ve bozulma olduğunda düzeltmelerini sağlayın.

Bunun dışında istediğiniz şekilde q ve r üzerinden kes yapıştıra çözüm ; varsa da benim bilgimi aşıyor olabilir.
Aslında çözüm yönteminiz makro çalıştırmak tüm sorunları çözüyor gibi gözüküyor ama bi yerden sonra bana hata verecektir.

Daha ayrıntılı anlatmam gerekirse, Evet en önemli nokta TK ile başlayan satırlar. Ben bu satırlara makro koyduğumda o satırların sorunu çözülecektir.

Bu arada TK dediğimiz havayolu uçuş numaraları. Bu listede TK dışında havayolları da olacağı için,
Benim verileri çektiğim sistem TK ile başlayan numaraları geliş/gidiş farklı satırlarda göstererek bana problem çıkartıyor ancak TK ile başlamayanları tek satırda düzenli gösteriyor.
Bu noktada yazdığım makro TK ile başlayanları düzeltirken, TK olmayan düzenli sütunları da yer değişikliği yaparak bozacaktır. Yani yine sorunu çözemiyorum
cileri33 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 13:26   #8
YUSUF44
Destek Ekibi
 
YUSUF44 kullanıcısının avatarı
 
Giriş: 04/01/2006
Şehir: Manisa, Kula
Mesaj: 6,708
Excel Vers. ve Dili:
İş : Ofis 2016 - Türkçe Ev: Ofis 2016 - Türkçe
Varsayılan

Q15'te aşağıdaki formülü:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(DOLAYLI("G"&SATIR());DATA1;2;0)
ve R15'te aşağıdaki formülü:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(DOLAYLI("H"&SATIR());DATA2;2;0)
Kullanıp, aşağıdaki hürelere kopyalayıp, sonra da kes yapıştır ile kontrol eder misiniz?
__________________


Sorularınızı örnek dosyayla desteklemeniz çözüme ulaşmanızı kolaylaştırır.

Altın Üye olmanızı öneririm. Altın Üye değilseniz dosyanızı dosya yükleme sitelerinden birine yükleyip linkini paylaşabilirsiniz.
YUSUF44 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-01-2018, 13:39   #9
cileri33
 
Giriş: 07/01/2018
Şehir: Mugla
Mesaj: 5
Excel Vers. ve Dili:
Excel 2010 TR
Varsayılan

Alıntı:
YUSUF44 tarafından gönderildi Mesajı Görüntüle
Q15'te aşağıdaki formülü:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(DOLAYLI("G"&SATIR());DATA1;2;0)
ve R15'te aşağıdaki formülü:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(DOLAYLI("H"&SATIR());DATA2;2;0)
Kullanıp, aşağıdaki hürelere kopyalayıp, sonra da kes yapıştır ile kontrol eder misiniz?
Yusuf Bey ve cems,
Yardımlarınız için çok teşekkür ederim.

Yusuf bey,
Verdiğiniz formül tam olarak problemimi çözdü.
İyi günler dilerim...
cileri33 Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 05:14


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Rampa- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Şişli Avukat- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Çorlu Havuz- Çorlu Havuz- Çorlu Perde Yıkama- Okul Danışmanlık- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım- Çorlu Sondaj- Çorlu Etüt- Futbol Cafe- Beylikdüzü Temizlik- Çorlu Kurs- Çorlu Ders- İzmit Mimar- Hurda Bakır Kablo- Hurda Bakır Kablo- Çorlu Pronet- Çorlu Yönetim- Çorlu Apartman Yönetimi- Çorlu Marangoz- Çorlu Avukat- Çorlu Su Arıtma- Çorlu Kompresör- İstanbul İnşaat-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden