Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 08-11-2017, 11:16   #1
bsuna
Altın Üye
 
Giriş: 02/02/2013
Şehir: istanbul
Mesaj: 11
Excel Vers. ve Dili:
türkçe
Varsayılan Aynı değere sahip isimlerin tekrarlaması

Merhaba arkadaşlar,

Ekteki dosyada TABLO sayfasında kodlar ve karşılığında değerler yer almakta. Ve LİSTE sayfasında, tablodaki değerlere sahip kodlar büyükten küçüğe doğru sıralanmaktadır. Fakat tabloda 0 değerine sahip 17 tane kod olduğu için Liste'nin sonuna baktığınızda 0 değerine sahip 17 satır tek bir kod şeklinde kendini tekrarlamakta. Bu tekrardan kaçınmak için kullanmam gereken formülü bir türlü bulamadım.

Yardımcı olursanız sevinirim.
Eklenmiş Dosyalar
Dosya Türü: xlsx ÖrnekTablo.xlsx (35.1 KB, 4 Görüntülenme)
bsuna Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-11-2017, 13:12   #2
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,000
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

C2:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=BÜYÜK(TABLO!$B$3:$B$250;SATIRSAY($C$2:C2))
B2: Dizi formülü olarak girişini yapın.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=İNDİS(TABLO!$A$3:$A$250;KÜÇÜK(EĞER(TABLO!$B$3:$B$250=C2
 ;SATIR(TABLO!$A$3:$A$250)-SATIR(TABLO!$A$3)+1);EĞERSAY($C$2:C2;C2)))
.
__________________
.
Ömer Çevrimiçi   Alıntı Yaparak Cevapla
Eski 08-11-2017, 13:28   #3
bsuna
Altın Üye
 
Giriş: 02/02/2013
Şehir: istanbul
Mesaj: 11
Excel Vers. ve Dili:
türkçe
Varsayılan

Alıntı:
Ömer tarafından gönderildi Mesajı Görüntüle
Merhaba,

C2:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=BÜYÜK(TABLO!$B$3:$B$250;SATIRSAY($C$2:C2))
B2: Dizi formülü olarak girişini yapın.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=İNDİS(TABLO!$A$3:$A$250;KÜÇÜK(EĞER(TABLO!$B$3:$B$250=C2
 ;SATIR(TABLO!$A$3:$A$250)-SATIR(TABLO!$A$3)+1);EĞERSAY($C$2:C2;C2)))
.
Ömer çok teşekkür ederim. Dizi formülü olmadan çözülebiliyor mu bu problem? Dizi formülünün mantığını tam kavrayamadığım için fonksiyonun nasıl kodlandığını anlayamıyorum. eğer dizi formülü olmadan yapılabiliyorsa formülü okuyup mantığını anlayabilirim.
Tekrar teşekkür ederim. Ellerine sağlık
bsuna Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-11-2017, 14:00   #4
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,000
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Linki inceler misiniz.

http://www.excel.web.tr/f122/syralam...ry-t23962.html

.
__________________
.
Ömer Çevrimiçi   Alıntı Yaparak Cevapla
Eski 08-11-2017, 15:02   #5
bsuna
Altın Üye
 
Giriş: 02/02/2013
Şehir: istanbul
Mesaj: 11
Excel Vers. ve Dili:
türkçe
Varsayılan

Alıntı:
Ömer tarafından gönderildi Mesajı Görüntüle
Teşekkürler, çok yardımcı oldu.
bsuna Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 17:18


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden