Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 08-11-2017, 10:16   #1
bsuna
Altın Üye
 
Giriş: 02/02/2013
Şehir: istanbul
Mesaj: 11
Excel Vers. ve Dili:
türkçe
Varsayılan Aynı değere sahip isimlerin tekrarlaması

Merhaba arkadaşlar,

Ekteki dosyada TABLO sayfasında kodlar ve karşılığında değerler yer almakta. Ve LİSTE sayfasında, tablodaki değerlere sahip kodlar büyükten küçüğe doğru sıralanmaktadır. Fakat tabloda 0 değerine sahip 17 tane kod olduğu için Liste'nin sonuna baktığınızda 0 değerine sahip 17 satır tek bir kod şeklinde kendini tekrarlamakta. Bu tekrardan kaçınmak için kullanmam gereken formülü bir türlü bulamadım.

Yardımcı olursanız sevinirim.
Eklenmiş Dosyalar
Dosya Türü: xlsx ÖrnekTablo.xlsx (35.1 KB, 4 Görüntülenme)
bsuna Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-11-2017, 12:12   #2
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,101
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

C2:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=BÜYÜK(TABLO!$B$3:$B$250;SATIRSAY($C$2:C2))
B2: Dizi formülü olarak girişini yapın.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=İNDİS(TABLO!$A$3:$A$250;KÜÇÜK(EĞER(TABLO!$B$3:$B$250=C2
 ;SATIR(TABLO!$A$3:$A$250)-SATIR(TABLO!$A$3)+1);EĞERSAY($C$2:C2;C2)))
.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-11-2017, 12:28   #3
bsuna
Altın Üye
 
Giriş: 02/02/2013
Şehir: istanbul
Mesaj: 11
Excel Vers. ve Dili:
türkçe
Varsayılan

Alıntı:
Ömer tarafından gönderildi Mesajı Görüntüle
Merhaba,

C2:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=BÜYÜK(TABLO!$B$3:$B$250;SATIRSAY($C$2:C2))
B2: Dizi formülü olarak girişini yapın.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=İNDİS(TABLO!$A$3:$A$250;KÜÇÜK(EĞER(TABLO!$B$3:$B$250=C2
 ;SATIR(TABLO!$A$3:$A$250)-SATIR(TABLO!$A$3)+1);EĞERSAY($C$2:C2;C2)))
.
Ömer çok teşekkür ederim. Dizi formülü olmadan çözülebiliyor mu bu problem? Dizi formülünün mantığını tam kavrayamadığım için fonksiyonun nasıl kodlandığını anlayamıyorum. eğer dizi formülü olmadan yapılabiliyorsa formülü okuyup mantığını anlayabilirim.
Tekrar teşekkür ederim. Ellerine sağlık
bsuna Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-11-2017, 13:00   #4
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 19,101
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Linki inceler misiniz.

http://www.excel.web.tr/f122/syralam...ry-t23962.html

.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-11-2017, 14:02   #5
bsuna
Altın Üye
 
Giriş: 02/02/2013
Şehir: istanbul
Mesaj: 11
Excel Vers. ve Dili:
türkçe
Varsayılan

Alıntı:
Ömer tarafından gönderildi Mesajı Görüntüle
Teşekkürler, çok yardımcı oldu.
bsuna Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 16:56


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Rampa- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Şişli Avukat- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Çorlu Havuz- Çorlu Havuz- Çorlu Perde Yıkama- Okul Danışmanlık- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım- Çorlu Sondaj- Çorlu Etüt- Futbol Cafe- Beylikdüzü Temizlik- Çorlu Kurs- Çorlu Ders- İzmit Mimar- Hurda Bakır Kablo- Hurda Bakır Kablo- Çorlu Pronet- Çorlu Yönetim- Çorlu Apartman Yönetimi- Çorlu Marangoz- Çorlu Avukat-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden