PDA

Tüm Versiyonu Göster : yazıyı sayıya çevirme


acemice
07-11-2008, 10:20
arkadaşlar formlarda bol miktarda sayıyı yazıya çeviren fomüller buldum ancak benim aradığım ise bunu tam tersi yani metni sayıya çevirmek
örnek : pazartsi ise 6 ; salı ise 4 cumartesi ie 4 olacak yardımcı olursanız memnun olurum

Ferhat Pazarçevirdi
07-11-2008, 13:22
Metnin A1 hücresinde olduğu kabulu ile; B2 hücresine aşağıdaki formülü giriniz.

=TOPLA.ÇARPIM(({"Pazartesi";"Salı";"Çarşamba";"Perşembe";"Cuma";"Cumartesi";"Pazar"}=A1)*{1;2;3;4;5;6;7})

Siz hangi güne, hangi rakamı verecekseniz, formüldeki dizileri ona göre düzeltiniz.

Salyangoz
21-03-2012, 15:18
Selamlar,

Benim de bir sorunum var aslında, elimde aşağıdaki gibi değerler var, bu bir programdan export edildiğinde text olarak excel'e yansıyor. Eğer numaraya çevirirsem olay dağalıyor, bende bu her bir text i gördüğümde karşılığına ona özgü bilgi yazmak istiyorum...

Kısacası A1 hücresinde 1-2-2 görürse TR-IST-Bakım, 2-3-3-2 görürse TR-IZM-Onarım Müdürü gibi yazılar yazmak istiyorum, öneriniz ne olur ? (Burada yazılanlar text) Sanırım istediğim yazıyı yazıya çevirmek gibi bir şey oluyor bu durumda

1-2-2
2-3-3-2
2-3-5
3-3-5
1-2-2
1-2-2
2-2
2-2
1-2-2
1-2-2

Korhan Ayhan
21-03-2012, 16:33
Merhaba,

Bu tarz verilerde bir tablo oluşturup DÜŞEYARA formülü ile istediğiniz sonuca ulaşabilirsiniz.

Boş bir sayfada (VERİ ismini verin) A sütununa mesela "1-2-2" değerini yazın. Hemen yanındaki hücreye bu değere karşılık gelecek değeri yazın. Bütün verilerinizi bu şekilde alt alta işleyin.

Daha sonra diyelimki bu şekilde text olan veriniz A1 hücresinde olsun.
Siz B1 hücresine aşağıdaki formülü uygulayın.

=DÜŞEYARA(A1;VERİ!A$1:B$1000;2;0)

Siz verilerinizin çokluğuna göre formüldeki aralıkları kendinize göre düzeltebilirsiniz.

Salyangoz
22-03-2012, 09:52
Bazen elimiz düşüncelerimiz tutuluyor gerçekten, en çok kullandığım formüldür VLOOKUP, sanırım sayıydı yazıydı derken yanlış açıdan bakmışım olaya, çok teşekkürler. Şimdi de forumda DÜŞEYARA sonucu #N/A olması durumunda hücreye bir şey yazdırabiliyor muyuz onu araştıracağım :) Tekrar teşekkürler

Salyangoz
22-03-2012, 10:01
#N/A sorunu ile ilgili de bir çok yardımcı mesaj gönderilmiş, tekrar teşekkürler.

=IF(D2="";"Test";IF(ISERROR(VLOOKUP(J3;Listeler!$E$2:$F$49;2;0));"Hatalı Tanımlama";VLOOKUP(J3;Listeler!$E$2:$F$49;2;0)))