Aşağı yuvarlamalı toplama [Archive] - Excel Forum

PDA

Tüm Versiyonu Göster : Aşağı yuvarlamalı toplama


zekigarden
12-01-2008, 12:24
Herkese selamlar sevgiler.
Benim sorum şu şekilde A1 hücresi 15,85 ; B1 hücresi 15,45 iki hücreyi C1 de topladığım zaman normal olarak 31,30 çıkıyorki bu normal değer. Ben C1 toplama değerinin 30 olmasını istiyorum yani virgülden sonraki değerlerin toplamaya dahil edilmesini istemiyorum. Kusuratların yukarı değil aşağı yuvarlanmasını. yada hiç toplamaya dahil edelmemesini istiyorum. Cevap için şimdiden teşekürler.

uzmanamele
12-01-2008, 12:28
merhaba
=YUVARLA((A1+B1);0)
buradaki 0 değeri virgülden sonraki basamak sayısıdır

Korhan Ayhan
12-01-2008, 12:29
Selamlar,

C1 hücresine aşağıdaki formülü uygulayıp denermisiniz.

=TOPLA.ÇARPIM((YUVARLA(A1:B1;0)))

Alternatif olarak aşağıdaki şekildede kullanabilirsiniz. Bu formülü tamamlarken CTRL+SHIFT+ENTER tuşlarına basarak (dizi formül) hücreyi terk etmeniz gerekmektedir. Aksi halde hata ile sonuçlanır.

=TOPLA(YUVARLA(A1:B1;0))

Ali
12-01-2008, 12:36
Alternatif;

=TAMSAYI(TOPLA(A1:A2))

zekigarden
12-01-2008, 12:45
Cevaplar için arkadaşlara teşekür ediyorum, ancak sonuç istediğim gibi çıkmıyor yani toplam değer 31 çıkıyor ben 30 olmasını istiyorum

uzmanamele
12-01-2008, 12:54
merhaba
verdiğiniz örneğe göre;
15,85+14,45=30,30
tamsayı olarakda 30
siz 10 un katları şeklinde mi görmek istiyorsunuz?

uzmanamele
12-01-2008, 13:00
merhaba
a1=15,85 ve b1=15,45 ise; c1 e yazılacak formül
=YUVARLA(((A1+B1)/100);1)*100

Erdal
12-01-2008, 13:00
merhabalar
c1'e
=A1+B1-(A1-TAMSAYI(A1)+B1-TAMSAYI(B1))
formülünü giriniz. Kolay gelsin

zekigarden
12-01-2008, 13:02
Uzmanamele Küçük bir düzeltme 15,85+15,45= 31,30 ediyor ben 15 iele 15 i tolasın istiyorum virgülden sonraki değerleri yani 85 ve 45 değerini hesaba katmasın diyorum

Ali
12-01-2008, 13:04
=TOPLA.ÇARPIM(TAMSAYI(A1:B1)) yazınız.

zekigarden
12-01-2008, 13:05
Uzamanamele ve somer bey çok teşekürler ikinizin ceaplarıda istediğim sonucu verdi çok çok teşekürler sağolun

uzmanamele
12-01-2008, 13:07
Uzmanamele Küçük bir düzeltme 15,85+15,45= 31,30 ediyor ben 15 iele 15 i tolasın istiyorum virgülden sonraki değerleri yani 85 ve 45 değerini hesaba katmasın diyorum

merhaba
ilk mesajınızdaki sayıları düzelttikten sonra benim toplama işlemimi düzeltme yoluna gitmeyin lütfen!

syn somer'in formülünde parantez ilave etmekte yarar var. hernekadar sonuç doğru çıksa da işlem sırası açısından önemli. toplama değilde çarpma işlemi olsaydı sonuç farkederdi dip not (farkedebilirdi)
=A1+B1-((A1-TAMSAYI(A1)+B1-TAMSAYI(B1)))

uzmanamele
12-01-2008, 13:13
merhaba
syn somer'in formülünde paranteze gerek yokmuş, yeterince dikkatli bakmamışım

zekigarden
12-01-2008, 13:16
Ben sizin işlemi düzeltmedim benim 15 yerine 14 yazdığım rakamı düzelttim yani ben kendi yanlışımı düzelterek tekrar yazdım. Neticede sonuca ulaştık Excel.web de emeği geçen herkese teşekürler kolay gelsin

Ali
12-01-2008, 13:23
=TOPLA.ÇARPIM(TAMSAYI(A1:B1)) yazınız.

Bizim cevap gümemi gitti?

O kadarda kısalttık.:)

uzmanamele
12-01-2008, 13:28
Ben sizin işlemi düzeltmedim benim 15 yerine 14 yazdığım rakamı düzelttim yani ben kendi yanlışımı düzelterek tekrar yazdım. Neticede sonuca ulaştık Excel.web de emeği geçen herkese teşekürler kolay gelsin

merhaba
siz üstünüze alınmayın ama bazı arkadaşlarımız sorusunu sorarken türkçe kelimeler kullanıyor ama kelimeler yanyana geldiğinde anlamlı bir türkçe cümle olmuyor. anladığımız kadarıyla soruya yardımcı olmaya çalıştığımızda ise, be salak herif, ben ne sormuşum sen ne anlatıyorsun anlamında cümlelerle cevap veriyor. siz ilk düzeltmeyi yaparken kendi yanlışınızı düzelttiğinizi belirtseyniniz mesele yoktu.
benim bu eleştirim şahsi değil, sizde üstünüze alınmayın. çabam, güzel Türkçemizi daha iyi konuşup yazmak konusuına dikkat çekmek.

zekigarden
12-01-2008, 13:30
Ali bey sizin cevapta doğru güme gitmedi sizede kocaman bir teşekürler sağolun

uzmanamele
12-01-2008, 13:30
Bizim cevap gümemi gitti?

O kadarda kısalttık.:)

merhaba syn Ali, sizin cevap neden güme gitsin? bukadar kısa bir formülü ben neden akıl edemedim diye hayıflanıyorum.
sebebi excel uzmanı olamamak galiba ;)

Ali
12-01-2008, 13:30
Buda dizi formüllü olanı;

=TOPLA(TAMSAYI(A1:B1))

yazıp direk entere basmadan CTRL+SHIFT+ENTER tuşlarına birlikte basarak formül girişini tamamlayınız.

Ali
12-01-2008, 13:32
merhaba syn Ali, sizin cevap neden güme gitsin? bukadar kısa bir formülü ben neden akıl edemedim diye hayıflanıyorum.
sebebi excel uzmanı olamamak galiba ;)


Kendi çapımda birşeyler yapmaya çalışıyorum.Siz değerli arkadaşlara faydalı olabiliyorsak ne mutlu..

yurttas
12-01-2008, 14:16
Herkese selamlar sevgiler.
Benim sorum şu şekilde A1 hücresi 15,85 ; B1 hücresi 15,45 iki hücreyi C1 de topladığım zaman normal olarak 31,30 çıkıyorki bu normal değer. Ben C1 toplama değerinin 30 olmasını istiyorum yani virgülden sonraki değerlerin toplamaya dahil edilmesini istemiyorum. Kusuratların yukarı değil aşağı yuvarlanmasını. yada hiç toplamaya dahil edelmemesini istiyorum. Cevap için şimdiden teşekürler.

=ROUND(SUM(A1:B1);-1)
=YUVARLA(TOPLA(A1:B1);-1)

Aşağıdaki linkte yer alan dosyayı inceleyin


http://www.excel.web.tr/showthread.php?t=18220

.