PDA

Tüm Versiyonu Göster : Aynı Hücrede, Eğer ve Yuvarla Topla Çarpım Formülü.


vitamin
07-07-2007, 10:26
Arkadaşlar ek'teki dosyada göndermiş olduğum çalışma için yardımlarınızı rica ediyorum..

Şimdiden herkese teşekkürler...

Ali
07-07-2007, 11:00
G1 ve G2 hücrelerinizdeki tarihlere göre toplam için

=TOPLA.ÇARPIM(--(A2:A32>=G1);--((A2:A32)<=G2);B2:B32)

yazınız.

Ortalama nasıl alınacak o kısmı biraz daha açarmısınız. Hangi kriterlere göre ne sonuç istiyorsunuz.

vitamin
07-07-2007, 11:25
Ali Bey, ilginiz için teşekkür ederim.

Yazmış olduğunuz formül istediğim tarihler arasındaki toplam sonucunu veriyor.

Talep ettiğiniz açıklamaya gelince;
Göndermiş olduğum çalışma sayfasındaki C34 hücresinde yazan "63"

01.07.2007 - 31.07.2007 Arası alınan müşteri çeklerinin,
Yuvarla Topla Çarpım formülü ile, ortalama gününü veriyor.

Benim istediğim ise,
G1 - G2 hücresindeki tarihleri değiştirdiğimde,
Hem Toplam Tutar, hem de Ort. Vade (63) G1 - G2 hücresindeki tarih aralığına göre sonuç versin...

İlginize tekrar teşekkür ediyorum...

Ali
07-07-2007, 11:36
Hangi kriterler ortalama derken normal ortalamamı,ağırlıklı ortalamamı onu kastetmiştim.63 nasıl elde edildi onu öğrenmek istemiştim.

vitamin
07-07-2007, 11:50
Ali Bey,

Göndermiş olduğum çalışma sayfasında,
C34 Hücresinde =YUVARLA(TOPLA.ÇARPIM(B2:B32;C2:C32)/B34; 0)
şeklinde bir formül var.

Bu formül bana, 01.07 - 31.07 arası Yapılan çek girişlerinin tutarlarına göre
ortalama günlerini veriyor.

Benim istediğim, G1 hücresini 03.07.2007, G2 hücresini 06.07.2007 yaptığımda,
B34 Hücresi,
B4:B7 arasını toplayarak 417.766,21 YTL. sonucunu,

C34 hücresi ise,
YUVARLA(TOPLA.ÇARPIM(B4:B7;C4:C7)/B34; 0) formülüne göre
64 Gün sonucunu versin.

Umarım anlatabilmişimdir.

İlginize tekrar teşekkürler...

Ali
07-07-2007, 12:50
Sn vitamin şu kısmı anlayamadım

Ayın 4'ünde 193,632,
5 inde 32,932,
6 sında ise 90,672 değeri var.

Sırası ile bunların karşısında 60,83,42 değerleri var. Ortalama alırken tarih aralığına göre 60+83+42 değerlerini toplayıptamı alacak.

Yoksa o tarih aralığında mesela ayın 4'ünde 60 değerini 193,632 ile çarpıp tüm değerlerinde çarpılmış değerlerine göre ağırlıklı ortalamamı olacak.

Daha öncede ağırlıkmı olacak yoksa normal mi diye sormuştum ama siz bunun cevabını vermediğiniz için cevapta uzadı.

vitamin
07-07-2007, 13:08
Ali Bey sizede zahmet oluyor fakat,

Dosyayı yeniden düzenleyerek daha açıklayıcı bir şekilde gönderiyorum.

Sanırım bu sefer daha açıklayıcı oldu.

İlginizi rica ediyor, teşekkür ediyorum...

Ali
07-07-2007, 13:29
B34

=TOPLA.ÇARPIM(--(A2:A32>=G1);--((A2:A32)<=G2);B2:B32))

C34

=YUVARLA(TOPLA.ÇARPIM((A2:A32>=G1)*((A2:A32)<=G2);(B2:B32) *(C2:C32))/TOPLA.ÇARPIM(--(A2:A32>=G1);--((A2:A32)<=G2);B2:B32);0)

vitamin
07-07-2007, 14:00
Ali Bey, çok teşekkürler.

Anlatmak biraz vakit aldı fakat sonunda oldu...